kernel: remove useless AddDepends/hid abstraction
[openwrt/svn-archive/archive.git] / package / kernel / linux / modules / input.mk
index 421a6b8fca7a69b444a088717eab5f7faccc683d..1e8b2f0257ea98a227dcb1681543afe482581218 100644 (file)
@@ -25,10 +25,10 @@ $(eval $(call KernelPackage,hid))
 define KernelPackage/hid-generic
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Generic HID device support
+  DEPENDS:=+kmod-hid
   KCONFIG:=CONFIG_HID_GENERIC
   FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
   AUTOLOAD:=$(call AutoProbe,hid-generic)
-  $(call AddDepends/hid)
 endef
 
 define KernelPackage/hid/description
@@ -82,6 +82,9 @@ endef
 define KernelPackage/input-gpio-keys/description
  This driver implements support for buttons connected
  to GPIO pins of various CPUs (and some other chips).
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys))
@@ -101,6 +104,9 @@ endef
 
 define KernelPackage/input-gpio-keys-polled/description
  Kernel module for support polled GPIO keys input device
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys-polled))
@@ -157,9 +163,8 @@ define KernelPackage/input-matrixkmap
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Input matrix devices support
   KCONFIG:=CONFIG_INPUT_MATRIXKMAP
-  DEPENDS:=@!LINUX_3_3
   FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
-  AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+  AUTOLOAD:=$(call AutoProbe,matrix-keymap)
   $(call AddDepends/input)
 endef
 
@@ -184,3 +189,21 @@ define KernelPackage/acpi-button/description
 endef
 
 $(eval $(call KernelPackage,acpi-button))
+
+
+define KernelPackage/keyboard-imx
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=IMX keypad support
+  DEPENDS:=@(TARGET_mxs||TARGET_imx6) +kmod-input-matrixkmap
+  KCONFIG:= \
+       CONFIG_KEYBOARD_IMX \
+       CONFIG_INPUT_KEYBOARD=y
+  FILES:=$(LINUX_DIR)/drivers/input/keyboard/imx_keypad.ko
+  AUTOLOAD:=$(call AutoProbe,imx_keypad)
+endef
+
+define KernelPackage/keyboard-imx/description
+ Enable support for IMX keypad port.
+endef
+
+$(eval $(call KernelPackage,keyboard-imx))