netsupport: move out mqprio from kmod-sched
[openwrt/staging/blogic.git] / package / kernel / linux / modules / input.mk
index 86ff33cb2612c17e123398b07c70ddc25493c9d5..99257b6725fc02de8cc1ada2b93a2ba6acd6ffca 100644 (file)
@@ -75,7 +75,7 @@ define KernelPackage/input-gpio-keys
        CONFIG_KEYBOARD_GPIO \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
-  AUTOLOAD:=$(call AutoProbe,gpio_keys)
+  AUTOLOAD:=$(call AutoProbe,gpio_keys,1)
 endef
 
 define KernelPackage/input-gpio-keys/description
@@ -112,7 +112,7 @@ $(eval $(call KernelPackage,input-gpio-keys-polled))
 
 define KernelPackage/input-gpio-encoder
   SUBMENU:=$(INPUT_MODULES_MENU)
-  TITLE:=GPIO rotay encoder
+  TITLE:=GPIO rotary encoder
   DEPENDS:=@GPIO_SUPPORT +kmod-input-core
   KCONFIG:=CONFIG_INPUT_GPIO_ROTARY_ENCODER
   FILES:=$(LINUX_DIR)/drivers/input/misc/rotary_encoder.ko
@@ -173,20 +173,23 @@ endef
 $(eval $(call KernelPackage,input-matrixkmap))
 
 
-define KernelPackage/acpi-button
+define KernelPackage/input-touchscreen-ads7846
   SUBMENU:=$(INPUT_MODULES_MENU)
-  TITLE:=ACPI Button Support
-  DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
-  KCONFIG:=CONFIG_ACPI_BUTTON
-  FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
-  AUTOLOAD:=$(call AutoLoad,06,button)
+  TITLE:=ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens
+  DEPENDS:=+kmod-hwmon-core +kmod-input-core +kmod-spi-bitbang
+  KCONFIG:= \
+       CONFIG_INPUT_TOUCHSCREEN=y \
+       CONFIG_TOUCHSCREEN_PROPERTIES=y \
+       CONFIG_TOUCHSCREEN_ADS7846
+  FILES:=$(LINUX_DIR)/drivers/input/touchscreen/ads7846.ko
+  AUTOLOAD:=$(call AutoProbe,ads7846)
 endef
 
-define KernelPackage/acpi-button/description
- Kernel module for ACPI Button support
+define KernelPackage/input-touchscreen-ads7846/description
+  Kernel module for ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens
 endef
 
-$(eval $(call KernelPackage,acpi-button))
+$(eval $(call KernelPackage,input-touchscreen-ads7846))
 
 
 define KernelPackage/keyboard-imx