kernel/modules/other/mlx_wdt: add new package
[openwrt/staging/pepe2k.git] / package / kernel / linux / modules / other.mk
index e227fd6a0f98ad25b4a63360fe81d1700b2d41c8..916fd08ba0cdf1bd760d990d7398f3901f14f0e9 100644 (file)
@@ -244,6 +244,28 @@ endef
 $(eval $(call KernelPackage,lkdtm))
 
 
+define KernelPackage/mlx_wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Mellanox Watchdog
+  DEPENDS:=@TARGET_x86 +kmod-regmap-core
+  KCONFIG:= \
+       CONFIG_MELLANOX_PLATFORM=y \
+       CONFIG_MLX_WDT
+  FILES:=$(LINUX_DIR)/drivers/watchdog/mlx_wdt.ko
+  AUTOLOAD:=$(call AutoProbe,mlx_wdt)
+endef
+
+define KernelPackage/mlx_wdt/description
+  This is the driver for the hardware watchdog on Mellanox systems.
+  This driver can be used together with the watchdog daemon.
+  It can also watch your kernel to make sure it doesn't freeze,
+  and if it does, it reboots your system after a certain amount of
+  time.
+endef
+
+$(eval $(call KernelPackage,mlx_wdt))
+
+
 define KernelPackage/pinctrl-mcp23s08
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Microchip MCP23xxx I/O expander