kernel: 5.10: fix kmod build failures
[openwrt/staging/rmilecki.git] / package / kernel / linux / modules / other.mk
index 83d998c83a5153360d337dca8283e44cc89aa608..cfd133f19f94f6b1d4658502cca247f5a2abfdce 100644 (file)
@@ -1126,7 +1126,9 @@ define KernelPackage/keys-trusted
   TITLE:=TPM trusted keys on kernel keyring
   DEPENDS:=@KERNEL_KEYS +kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha1 +kmod-tpm
   KCONFIG:=CONFIG_TRUSTED_KEYS
-  FILES:=$(LINUX_DIR)/security/keys/trusted.ko
+  FILES:= \
+         $(LINUX_DIR)/security/keys/trusted.ko@lt5.10 \
+         $(LINUX_DIR)/security/keys/trusted-keys/trusted.ko@ge5.10
   AUTOLOAD:=$(call AutoLoad,01,trusted-keys,1)
 endef