kernel: crypto: limit crypto-hw-hifn-795x to devices with pci support
[openwrt/openwrt.git] / package / kernel / linux / modules / sound.mk
index 2c11d078e16bb815dcb1058480bdfcf545202af3..e43be25bc67143f4f5fa4c0f2eefdc1840f763e5 100644 (file)
@@ -304,10 +304,7 @@ $(eval $(call KernelPackage,sound-dummy))
 define KernelPackage/sound-hda-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=HD Audio Sound Core Support
-  DEPENDS:= \
-       +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-realtek:kmod-ledtrig-audio \
-       +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-conexant:kmod-ledtrig-audio \
-       +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-idt:kmod-ledtrig-audio
+  DEPENDS:=+kmod-ledtrig-audio
   KCONFIG:= \
        CONFIG_SND_HDA_CORE \
        CONFIG_SND_HDA_HWDEP=y \