kernel: remove omap24xx specific kernel module packages
[openwrt/staging/yousong.git] / package / kernel / linux / modules / spi.mk
index 0b535a8cb485cc1b36fb68a96403e7af5a8a287b..1c2a789fedc153aedfb81daab93f5c76a4a01929 100644 (file)
@@ -89,20 +89,3 @@ define KernelPackage/spi-dev/description
 endef
 
 $(eval $(call KernelPackage,spi-dev))
-
-define KernelPackage/spi-omap-24xx
-  SUBMENU:=$(SPI_MENU)
-  TITLE:=SPI omap 24xx
-  DEPENDS:=@TARGET_omap24xx
-  KCONFIG:=CONFIG_SPI_OMAP24XX \
-          CONFIG_SPI=y \
-          CONFIG_SPI_MASTER=y
-  FILES:=$(LINUX_DIR)/drivers/spi/spi-omap2-mcspi.ko
-  AUTOLOAD:=$(call AutoProbe,spi-omap2-mcspi)
-endef
-
-define KernelPackage/spi-dev/description
- This package contains the user mode SPI device driver
-endef
-
-$(eval $(call KernelPackage,spi-omap-24xx))