treewide: remove all @{lt,gt,ge,le} appearances affecting 5.10 kernel
[openwrt/openwrt.git] / package / kernel / linux / modules / spi.mk
index 416209825f57cbf1857d1718da3925561ec50465..78a1c8a03283b21fcecc2ff7394f7803ce4ce8f2 100644 (file)
@@ -14,8 +14,10 @@ define KernelPackage/mmc-spi
   KCONFIG:=CONFIG_MMC_SPI \
           CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
-  FILES:=$(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
-  AUTOLOAD:=$(call AutoLoad,90,mmc_spi)
+  FILES:=\
+       $(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko \
+       $(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
+  AUTOLOAD:=$(call AutoProbe,of_mmc_spi mmc_spi)
 endef
 
 define KernelPackage/mmc-spi/description
@@ -32,7 +34,6 @@ define KernelPackage/spi-bitbang
           CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
   FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
-  AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
 endef
 
 define KernelPackage/spi-bitbang/description
@@ -42,28 +43,13 @@ endef
 $(eval $(call KernelPackage,spi-bitbang))
 
 
-define KernelPackage/spi-gpio-old
-  SUBMENU:=$(SPI_MENU)
-  TITLE:=Old GPIO based bitbanging SPI controller (DEPRECATED)
-  DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
-  KCONFIG:=CONFIG_SPI_GPIO_OLD
-  FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio_old.ko
-  AUTOLOAD:=$(call AutoLoad,92,spi_gpio_old)
-endef
-
-define KernelPackage/spi-gpio-old/description
- This package contains the GPIO based bitbanging SPI controller driver
-endef
-
-$(eval $(call KernelPackage,spi-gpio-old))
-
 define KernelPackage/spi-gpio
   SUBMENU:=$(SPI_MENU)
   TITLE:=GPIO-based bitbanging SPI Master
   DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
   KCONFIG:=CONFIG_SPI_GPIO
   FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
-  AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
+  AUTOLOAD:=$(call AutoProbe,spi-gpio)
 endef
 
 define KernelPackage/spi-gpio/description
@@ -79,7 +65,7 @@ define KernelPackage/spi-dev
           CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
   FILES:=$(LINUX_DIR)/drivers/spi/spidev.ko
-  AUTOLOAD:=$(call AutoLoad,93,spidev)
+  AUTOLOAD:=$(call AutoProbe,spidev)
 endef
 
 define KernelPackage/spi-dev/description
@@ -87,4 +73,3 @@ define KernelPackage/spi-dev/description
 endef
 
 $(eval $(call KernelPackage,spi-dev))
-