mac80211: Update to version 5.15.58-1
[openwrt/staging/wigyori.git] / package / kernel / mac80211 / patches / build / 060-no_local_ssb_bcma.patch
index 290d254238a4f0b686e6dfc5f50f7a359860545f..089ff2117bd94f1485e7e454d955b003486c6215 100644 (file)
@@ -1,9 +1,9 @@
 --- a/local-symbols
 +++ b/local-symbols
-@@ -412,43 +412,6 @@ USB_SIERRA_NET=
- USB_VL600=
+@@ -451,43 +451,6 @@ USB_VL600=
  USB_NET_CH9200=
  USB_NET_AQC111=
+ USB_RTL8153_ECM=
 -SSB_POSSIBLE=
 -SSB=
 -SSB_SPROM=
@@ -69,7 +69,7 @@
        depends on B43 && B43_SSB && SSB_SDIOHOST_POSSIBLE
 -      select SSB_SDIOHOST
 +      depends on SSB_SDIOHOST
-       ---help---
+       help
          Broadcom 43xx device support for Soft-MAC SDIO devices.
  
 @@ -96,13 +96,13 @@ config B43_SDIO
@@ -90,7 +90,7 @@
  config B43_PHY_G
 --- a/drivers/net/wireless/broadcom/b43/main.c
 +++ b/drivers/net/wireless/broadcom/b43/main.c
-@@ -2851,7 +2851,7 @@ static struct ssb_device *b43_ssb_gpio_d
+@@ -2853,7 +2853,7 @@ static struct ssb_device *b43_ssb_gpio_d
  {
        struct ssb_bus *bus = dev->dev->sdev->bus;
  
@@ -99,7 +99,7 @@
        return (bus->chipco.dev ? bus->chipco.dev : bus->pcicore.dev);
  #else
        return bus->chipco.dev;
-@@ -4868,7 +4868,7 @@ static int b43_wireless_core_init(struct
+@@ -4870,7 +4870,7 @@ static int b43_wireless_core_init(struct
        }
        if (sprom->boardflags_lo & B43_BFL_XTAL_NOSLOW)
                hf |= B43_HF_DSCRQ; /* Disable slowclock requests from ucode. */
 -      select SSB
 +      depends on SSB
        depends on FW_LOADER
-       ---help---
+       help
          b43legacy is a driver for 802.11b devices from Broadcom (BCM4301 and
 @@ -25,15 +25,15 @@ config B43LEGACY
  config B43LEGACY_PCI_AUTOSELECT
  # LED support
 --- a/drivers/net/wireless/broadcom/b43legacy/main.c
 +++ b/drivers/net/wireless/broadcom/b43legacy/main.c
-@@ -1906,7 +1906,7 @@ static int b43legacy_gpio_init(struct b4
+@@ -1907,7 +1907,7 @@ static int b43legacy_gpio_init(struct b4
        if (dev->dev->id.revision >= 2)
                mask  |= 0x0010; /* FIXME: This is redundant. */
  
        pcidev = bus->pcicore.dev;
  #endif
        gpiodev = bus->chipco.dev ? : pcidev;
-@@ -1925,7 +1925,7 @@ static void b43legacy_gpio_cleanup(struc
+@@ -1926,7 +1926,7 @@ static void b43legacy_gpio_cleanup(struc
        struct ssb_bus *bus = dev->dev->bus;
        struct ssb_device *gpiodev, *pcidev = NULL;
  
        gpiodev = bus->chipco.dev ? : pcidev;
 --- a/drivers/net/wireless/broadcom/brcm80211/brcmsmac/led.h
 +++ b/drivers/net/wireless/broadcom/brcm80211/brcmsmac/led.h
-@@ -22,7 +22,7 @@ struct brcms_led {
-       bool active_low;
+@@ -24,7 +24,7 @@ struct brcms_led {
+       struct gpio_desc *gpiod;
  };
  
 -#ifdef CPTCFG_BCMA_DRIVER_GPIO
        select BRCMUTIL
 --- a/Kconfig.local
 +++ b/Kconfig.local
-@@ -1240,117 +1240,6 @@ config BACKPORTED_USB_NET_CH9200
- config BACKPORTED_USB_NET_AQC111
+@@ -1357,117 +1357,6 @@ config BACKPORTED_USB_NET_AQC111
+ config BACKPORTED_USB_RTL8153_ECM
        tristate
-       default USB_NET_AQC111
+       default USB_RTL8153_ECM
 -config BACKPORTED_SSB_POSSIBLE
 -      tristate
 -      default SSB_POSSIBLE
        default USB_ACM
 --- a/Kconfig.sources
 +++ b/Kconfig.sources
-@@ -7,9 +7,6 @@ source "$BACKPORT_DIR/net/mac80211/Kconf
+@@ -10,9 +10,6 @@ source "$BACKPORT_DIR/drivers/soc/qcom/K
  source "$BACKPORT_DIR/drivers/net/wireless/Kconfig"
  source "$BACKPORT_DIR/drivers/net/usb/Kconfig"
  
  source "$BACKPORT_DIR/drivers/staging/Kconfig"
 --- a/Makefile.kernel
 +++ b/Makefile.kernel
-@@ -40,8 +40,6 @@ obj-y += compat/
- obj-$(CPTCFG_CFG80211) += net/wireless/
- obj-$(CPTCFG_MAC80211) += net/mac80211/
+@@ -43,8 +43,6 @@ obj-$(CPTCFG_QRTR) += net/qrtr/
+ obj-$(CPTCFG_QCOM_QMI_HELPERS) += drivers/soc/qcom/
+ obj-$(CPTCFG_MHI_BUS) += drivers/bus/mhi/
  obj-$(CPTCFG_WLAN) += drivers/net/wireless/
 -obj-$(CPTCFG_SSB) += drivers/ssb/
 -obj-$(CPTCFG_BCMA) += drivers/bcma/