iptables: package hashlimit module (#6696)
[openwrt/staging/dedeckeh.git] / package / kernel / modules / netfilter.mk
index 561286efda7f2f44319538919940f6f1647c7b89..510c195d6231d43a2f5188524f9a954f904a0f0c 100644 (file)
@@ -512,3 +512,17 @@ define KernelPackage/nf-conntrack-netlink/description
 endef
 
 $(eval $(call KernelPackage,nf-conntrack-netlink))
+
+define KernelPackage/ipt-hashlimit
+$(call KernelPackage/ipt/Depends,)
+  TITLE:=Netfilter hashlimit match
+  FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.$(LINUX_KMOD_SUFFIX)
+  KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
+  AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)
+endef
+
+define KernelPackage/ipt-hashlimit/description
+ Kernel modules support for the hashlimit bucket match module
+endef
+
+$(eval $(call KernelPackage,ipt-hashlimit))