package/kernel: Remove $(KMOD_SUFFIX) usage
[openwrt/svn-archive/archive.git] / package / kernel / modules / netfilter.mk
index 919e8ad19d0e330a4692e7e2f06264f9d032d815..d24329fae515e20dbb4b99e72289208e9e6bceb5 100644 (file)
@@ -283,7 +283,7 @@ $(eval $(call KernelPackage,ipt-debug))
 define KernelPackage/ipt-led
   TITLE:=Module to trigger a LED with a Netfilter rule
   KCONFIG:=$(KCONFIG_IPT_LED)
-  FILES:=$(foreach mod,$(IPT_LED-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  FILES:=$(foreach mod,$(IPT_LED-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,61,$(notdir $(IPT_LED-m)))
   $(call AddDepends/ipt)
 endef
@@ -296,6 +296,7 @@ $(eval $(call KernelPackage,ipt-led))
 
 define KernelPackage/ipt-tproxy
   TITLE:=Transparent proxying support
+  DEPENDS+=+IPV6:kmod-ipv6
   KCONFIG:= \
        CONFIG_NETFILTER_TPROXY \
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
@@ -303,7 +304,7 @@ define KernelPackage/ipt-tproxy
   FILES:= \
        $(LINUX_DIR)/net/netfilter/nf_tproxy_core.ko \
        $(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
-  AUTOLOAD:=$(call AutoLoad,45,$(notdir nf_tproxy_core $(IPT_TPROXY-m)))
+  AUTOLOAD:=$(call AutoLoad,50,$(notdir nf_tproxy_core $(IPT_TPROXY-m)))
   $(call AddDepends/ipt)
 endef