move library packages to package/libs/
[openwrt/staging/mkresin.git] / package / libreadline / Makefile
diff --git a/package/libreadline/Makefile b/package/libreadline/Makefile
deleted file mode 100644 (file)
index 90219e5..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=readline
-PKG_VERSION:=5.2
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/readline
-PKG_MD5SUM:=e39331f32ad14009b9ff49cc10c5e751
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libreadline
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Command lines edition library
-  URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
-endef
-
-define Package/libreadline/description
-       The Readline library provides a set of functions for use by applications 
-       that allow users to edit command lines as they are typed in. Both Emacs 
-       and vi editing modes are available. The Readline library includes 
-       additional functions to maintain a list of previously-entered command 
-       lines, to recall and perhaps reedit those lines, and perform csh-like 
-       history expansion on previous commands.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-curses \
-       )
-endef
-
-TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.5,so.5.2} $(1)/usr/lib/
-endef
-
-define Package/libreadline/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.5,so.5.2} $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libreadline))