libusb: add from /packages, add myself as maintainer
[openwrt/staging/mkresin.git] / package / libs / libusb / Makefile
diff --git a/package/libs/libusb/Makefile b/package/libs/libusb/Makefile
new file mode 100644 (file)
index 0000000..d1bdb01
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libusb
+PKG_VERSION:=1.0.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libusb-1.0
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A library for accessing Linux USB devices
+  DEPENDS:=+libpthread +librt
+  URL:=http://libusb.wiki.sourceforge.net/
+endef
+
+define Package/libusb-1.0/description
+  libusb is a C library that gives applications easy access to USB devices on
+  many different operating systems.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libusb-1.0/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libusb-1.0))