libs/zlib: bump to latest stable release 1.2.12 (CVE-2018-25032)
[openwrt/staging/wigyori.git] / package / libs / zlib / patches / 001-neon-implementation-of-adler32.patch
index 843ef45c7d7b593277aacee057e410dcc40a9531..9ed784e3d333bcf525eae370662b01e129f35b79 100644 (file)
@@ -21,11 +21,9 @@ https://bugs.chromium.org/p/chromium/issues/detail?id=688601
  4 files changed, 166 insertions(+), 8 deletions(-)
  create mode 100644 contrib/arm/neon_adler32.c
 
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0fe939df..8e75f664 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -7,6 +7,7 @@ set(VERSION "1.2.11")
+@@ -7,6 +7,7 @@ set(VERSION "1.2.12")
  
  option(ASM686 "Enable building i686 assembly implementation")
  option(AMD64 "Enable building amd64 assembly implementation")
@@ -94,23 +92,18 @@ index d0be4380..45ebaa4b 100644
  }
  
  /* ========================================================================= */
-diff --git a/contrib/README.contrib b/contrib/README.contrib
-index a411d5c3..3fd1d202 100644
 --- a/contrib/README.contrib
 +++ b/contrib/README.contrib
-@@ -12,6 +12,9 @@ amd64/      by Mikhail Teterin <mi@ALDAN.algebra.com>
-         asm code for AMD64
-         See patch at http://www.freebsd.org/cgi/query-pr.cgi?pr=bin/96393
+@@ -8,6 +8,9 @@ ada/        by Dmitriy Anisimkov <anisim
+         Support for Ada
+         See http://zlib-ada.sourceforge.net/
  
 +arm/        by Adenilson Cavalcanti <cavalcantii@chromium.org>
 +        ARM optimizations (NEON and ARMv8 code).
 +
- asm686/     by Brian Raiter <breadbox@muppetlabs.com>
-         asm code for Pentium and PPro/PII, using the AT&T (GNU as) syntax
-         See http://www.muppetlabs.com/~breadbox/software/assembly.html
-diff --git a/contrib/arm/neon_adler32.c b/contrib/arm/neon_adler32.c
-new file mode 100644
-index 00000000..f173a74f
+ blast/      by Mark Adler <madler@alumni.caltech.edu>
+         Decompressor for output of PKWare Data Compression Library (DCL)
 --- /dev/null
 +++ b/contrib/arm/neon_adler32.c
 @@ -0,0 +1,137 @@