More libtool madness: Every package which was using c++ and libtool fixup
[openwrt/svn-archive/archive.git] / package / libtool / Makefile
index 699e537cb391131c7a0e3641cbe7f2161f185762..8d50a7adacb0c136c3a543340a9170e8fbc0d1d5 100644 (file)
@@ -19,6 +19,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 HOST_PATCH_DIR=/dev/null
 
+PKG_BUILD_DEPENDS:=libtool/host
+
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,6 +45,8 @@ define Build/InstallDev
        mv $(2)/lib/* $(1)/usr/lib/
        mv $(2)/include/* $(1)/usr/include/
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
+       $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
+       $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
 endef
 
 define Package/libltdl/install