move lots of kernel related packages to the new system/ folder
[openwrt/openwrt.git] / package / ltq-dsl-app / Makefile
diff --git a/package/ltq-dsl-app/Makefile b/package/ltq-dsl-app/Makefile
deleted file mode 100644 (file)
index 8985484..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=dsl_cpe_control_danube
-PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
-PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-PKG_CONFIG_DEPENDS:=\
-       CONFIG_LTQ_DSL_ENABLE_SOAP \
-       CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING
-
-include $(INCLUDE_DIR)/package.mk
-
-PKG_BUILD_DEPENDS:=TARGET_lantiq_danube:kmod-ltq-dsl-danube TARGET_lantiq_ar9:kmod-ltq-dsl-ar9 \
-       TARGET_lantiq_vr9:kmod-ltq-dsl-vr9 TARGET_lantiq_ase:kmod-ltq-dsl-ase
-
-define Package/ltq-dsl-app
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Lantiq DSL userland tool
-  URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq&&!(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable) +libpthread
-  MENU:=1
-endef
-
-define Package/ltq-dsl-app/description
-       Infineon DSL CPE API for Amazon SE, Danube and Vinax.
-endef
-
-define Package/ltq-dsl-app/config
-       source "$(SOURCE)/Config.in"
-endef
-
-LTQ_DSL_MAX_DEVICE=1
-LTQ_DSL_LINES_PER_DEVICE=1
-LTQ_DSL_CHANNELS_PER_LINE=1
-
-CONFIGURE_ARGS += \
-       --with-max-device="$(LTQ_DSL_MAX_DEVICE)" \
-       --with-lines-per-device="$(LTQ_DSL_LINES_PER_DEVICE)" \
-       --with-channels-per-line="$(LTQ_DSL_CHANNELS_PER_LINE)" \
-       --enable-danube \
-       --enable-driver-include="-I$(STAGING_DIR)/usr/include" \
-       --enable-debug-prints \
-       --enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
-       --enable-cli-support \
-       --enable-cmv-scripts \
-       --enable-debug-tool-interface \
-       --enable-adsl-led \
-       --enable-dsl-ceoc \
-       --enable-script-notification \
-       --enable-dsl-pm \
-       --enable-dsl-pm-total \
-       --enable-dsl-pm-history \
-       --enable-dsl-pm-showtime \
-       --enable-dsl-pm-channel-counters \
-       --enable-dsl-pm-datapath-counters \
-       --enable-dsl-pm-line-counters \
-       --enable-dsl-pm-channel-thresholds \
-       --enable-dsl-pm-datapath-thresholds \
-       --enable-dsl-pm-line-thresholds \
-       --enable-dsl-pm-optional-parameters
-
-ifeq ($(CONFIG_LTQ_DSL_ENABLE_SOAP),y)
-CONFIGURE_ARGS += \
-       --enable-soap-support
-endif
-
-ifeq ($(CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING),y)
-CONFIGURE_ARGS += \
-       --enable-dsl-event-polling
-endif
-
-TARGET_CFLAGS += -I$(LINUX_DIR)/include
-
-define Package/ltq-dsl-app/install
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
-
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
-       $(INSTALL_BIN) ./files/dsl_notify.sh $(1)/sbin
-endef
-
-$(eval $(call BuildPackage,ltq-dsl-app))