madwifi: handle frame classification properly if eth->h_proto contains the protocol...
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 102-multicall_binary.patch
index 3fa40eb708b0d4c386cb6f8047250b7aefd5bd92..887a462e9fe0e029530ee3b7011c1b98b3642e6a 100644 (file)
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/tools/80211debug.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/80211debug.c        2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/80211debug.c     2008-05-19 14:15:10.000000000 +0200
+--- a/tools/80211debug.c
++++ b/tools/80211debug.c
 @@ -48,6 +48,7 @@
  #include <ctype.h>
  #include <getopt.h>
@@ -10,7 +8,7 @@ Index: madwifi-trunk-r3314/tools/80211debug.c
  
  #undef ARRAY_SIZE
  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -185,7 +186,7 @@
+@@ -185,7 +186,7 @@ sysctlbyname(const char *oid0, void *old
  #endif /* __linux__ */
  
  int
@@ -19,10 +17,8 @@ Index: madwifi-trunk-r3314/tools/80211debug.c
  {
        const char *ifname = "ath0";
        const char *cp, *tp;
-Index: madwifi-trunk-r3314/tools/80211stats.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/80211stats.c        2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/80211stats.c     2008-05-19 14:16:17.000000000 +0200
+--- a/tools/80211stats.c
++++ b/tools/80211stats.c
 @@ -59,6 +59,7 @@
  #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
@@ -31,7 +27,7 @@ Index: madwifi-trunk-r3314/tools/80211stats.c
  
  #ifndef SIOCG80211STATS
  #define       SIOCG80211STATS (SIOCDEVPRIVATE + 2)
-@@ -240,7 +241,7 @@
+@@ -240,7 +241,7 @@ print_sta_stats(FILE *fd, const u_int8_t
  }
  
  int
@@ -40,10 +36,8 @@ Index: madwifi-trunk-r3314/tools/80211stats.c
  {
        int c, len;
        struct ieee80211req_sta_info *si;
-Index: madwifi-trunk-r3314/tools/athchans.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/athchans.c  2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/athchans.c       2008-05-19 14:15:28.000000000 +0200
+--- a/tools/athchans.c
++++ b/tools/athchans.c
 @@ -58,6 +58,7 @@
  #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
@@ -52,7 +46,7 @@ Index: madwifi-trunk-r3314/tools/athchans.c
  
  static        int s = -1;
  static const char *progname;
-@@ -140,8 +141,9 @@
+@@ -140,8 +141,9 @@ usage(void)
  }
  
  #define       MAXCHAN ((int)(sizeof(struct ieee80211req_chanlist) * NBBY))
@@ -63,10 +57,8 @@ Index: madwifi-trunk-r3314/tools/athchans.c
  {
        const char *ifname = "wifi0";
        struct ieee80211req_chanlist chanlist;
-Index: madwifi-trunk-r3314/tools/athctrl.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/athctrl.c   2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/athctrl.c        2008-05-19 14:15:44.000000000 +0200
+--- a/tools/athctrl.c
++++ b/tools/athctrl.c
 @@ -52,6 +52,7 @@
  #include <err.h>
  
@@ -75,7 +67,7 @@ Index: madwifi-trunk-r3314/tools/athctrl.c
  
  static int
  setsysctrl(const char *dev, const char *control , u_long value)
-@@ -88,7 +89,7 @@
+@@ -88,7 +89,7 @@ static void usage(void)
  }
  
  int
@@ -84,10 +76,8 @@ Index: madwifi-trunk-r3314/tools/athctrl.c
  {
        char device[IFNAMSIZ + 1];
        int distance = -1;
-Index: madwifi-trunk-r3314/tools/athdebug.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/athdebug.c  2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/athdebug.c       2008-05-19 14:15:59.000000000 +0200
+--- a/tools/athdebug.c
++++ b/tools/athdebug.c
 @@ -51,6 +51,7 @@
  #include <ctype.h>
  #include <getopt.h>
@@ -96,7 +86,7 @@ Index: madwifi-trunk-r3314/tools/athdebug.c
  
  #undef ARRAY_SIZE
  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -194,7 +195,7 @@
+@@ -194,7 +195,7 @@ sysctlbyname(const char *oid0, void *old
  #endif /* __linux__ */
  
  int
@@ -105,10 +95,8 @@ Index: madwifi-trunk-r3314/tools/athdebug.c
  {
  #ifdef __linux__
        const char *ifname = "wifi0";
-Index: madwifi-trunk-r3314/tools/athkey.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/athkey.c    2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/athkey.c 2008-05-19 14:13:06.000000000 +0200
+--- a/tools/athkey.c
++++ b/tools/athkey.c
 @@ -58,6 +58,7 @@
  #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
@@ -117,7 +105,7 @@ Index: madwifi-trunk-r3314/tools/athkey.c
  
  static int s = -1;
  static const char *progname;
-@@ -213,8 +214,7 @@
+@@ -213,8 +214,7 @@ usage(void)
        exit(-1);
  }
  
@@ -127,10 +115,8 @@ Index: madwifi-trunk-r3314/tools/athkey.c
  {
        const char *ifname = "wifi0";
        struct ieee80211req_key setkey;
-Index: madwifi-trunk-r3314/tools/athstats.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/athstats.c  2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/athstats.c       2008-05-19 14:13:44.000000000 +0200
+--- a/tools/athstats.c
++++ b/tools/athstats.c
 @@ -65,6 +65,7 @@
  
  #undef ARRAY_SIZE
@@ -139,7 +125,7 @@ Index: madwifi-trunk-r3314/tools/athstats.c
  
  static const struct {
        u_int           phyerr;
-@@ -228,7 +229,7 @@
+@@ -228,7 +229,7 @@ catchalarm(int signo)
  }
  
  int
@@ -148,12 +134,11 @@ Index: madwifi-trunk-r3314/tools/athstats.c
  {
  #ifdef __linux__
        const char *ifname = "wifi0";
-Index: madwifi-trunk-r3314/tools/do_multi.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-trunk-r3314/tools/do_multi.c       2008-05-19 14:56:28.000000000 +0200
-@@ -0,0 +1,32 @@
+--- /dev/null
++++ b/tools/do_multi.c
+@@ -0,0 +1,33 @@
 +#include <string.h>
++#include <libgen.h>
 +#include "do_multi.h"
 +
 +int
@@ -185,10 +170,8 @@ Index: madwifi-trunk-r3314/tools/do_multi.c
 +
 +    return ret;
 +}
-Index: madwifi-trunk-r3314/tools/do_multi.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-trunk-r3314/tools/do_multi.h       2008-05-19 14:42:44.000000000 +0200
+--- /dev/null
++++ b/tools/do_multi.h
 @@ -0,0 +1,15 @@
 +#ifdef DO_MULTI
 +int a80211debug_init(int argc, char *argv[]);
@@ -205,11 +188,9 @@ Index: madwifi-trunk-r3314/tools/do_multi.h
 +#else
 +#define CMD(name) main
 +#endif
-Index: madwifi-trunk-r3314/tools/Makefile
-===================================================================
---- madwifi-trunk-r3314.orig/tools/Makefile    2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/Makefile 2008-05-19 14:56:55.000000000 +0200
-@@ -46,56 +46,55 @@
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -46,56 +46,55 @@ ifeq ($(HAL),)
  HAL=   $(TOP)/hal
  endif
  
@@ -293,10 +274,8 @@ Index: madwifi-trunk-r3314/tools/Makefile
  clean:
 -      rm -f $(ALL) core a.out
 +      rm -f $(ALLPROGS) madwifi_multi *.o core a.out
-Index: madwifi-trunk-r3314/tools/wlanconfig.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/wlanconfig.c        2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/wlanconfig.c     2008-05-19 14:14:07.000000000 +0200
+--- a/tools/wlanconfig.c
++++ b/tools/wlanconfig.c
 @@ -61,6 +61,7 @@
  #include "net80211/ieee80211.h"
  #include "net80211/ieee80211_crypto.h"
@@ -305,7 +284,7 @@ Index: madwifi-trunk-r3314/tools/wlanconfig.c
  
  /*
   * These are taken from ieee80211_node.h
-@@ -100,7 +101,7 @@
+@@ -100,7 +101,7 @@ size_t strlcat(char *, const char *, siz
  static int verbose = 0;
  
  int
@@ -314,10 +293,8 @@ Index: madwifi-trunk-r3314/tools/wlanconfig.c
  {
        const char *ifname, *cmd;
        unsigned char bnounit = 0;
-Index: madwifi-trunk-r3314/tools/ath_info.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/ath_info.c  2008-05-19 13:58:46.000000000 +0200
-+++ madwifi-trunk-r3314/tools/ath_info.c       2008-05-19 14:44:45.000000000 +0200
+--- a/tools/ath_info.c
++++ b/tools/ath_info.c
 @@ -98,6 +98,7 @@
  #include <sys/mman.h>
  #include <endian.h>
@@ -326,7 +303,7 @@ Index: madwifi-trunk-r3314/tools/ath_info.c
  
  #undef ARRAY_SIZE
  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -738,7 +739,8 @@
+@@ -738,7 +739,8 @@ static void usage(const char *n)
                "unlawful radio transmissions!\n\n");
  }