madwifi patch cleanup and stability fixes - fix a semi-random heisenbug by replacing...
[openwrt/openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index c05218461e9a1e0d013871ab1fea5da52400c1cf..542c6c808c453a714a783d7fb35277a7945aae68 100644 (file)
@@ -1,7 +1,5 @@
-Index: madwifi-trunk-r3314/ath/if_ath.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath.c      2008-03-07 01:47:43.177523993 +0100
-+++ madwifi-trunk-r3314/ath/if_ath.c   2008-03-07 01:47:43.193516906 +0100
+--- a/ath/if_ath.c
++++ b/ath/if_ath.c
 @@ -42,7 +42,6 @@
   * This software is derived from work of Atsushi Onoe; his contribution
   * is greatly appreciated.
@@ -101,10 +99,8 @@ Index: madwifi-trunk-r3314/ath/if_ath.c
  /* If we are shutting down or blowing off the DFS channel availability check
   * then we call this to stop the behavior before we take the rest of the
   * necessary actions (such as a DFS reaction to radar). */
-Index: madwifi-trunk-r3314/ath_rate/amrr/amrr.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/amrr/amrr.c      2008-03-07 01:45:09.410373793 +0100
-+++ madwifi-trunk-r3314/ath_rate/amrr/amrr.c   2008-03-07 01:47:43.193516906 +0100
+--- a/ath_rate/amrr/amrr.c
++++ b/ath_rate/amrr/amrr.c
 @@ -70,7 +70,9 @@
  
  #include "amrr.h"
@@ -115,10 +111,8 @@ Index: madwifi-trunk-r3314/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-Index: madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/minstrel/minstrel.c      2008-03-07 01:45:09.418374247 +0100
-+++ madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c   2008-03-07 01:47:43.201513363 +0100
+--- a/ath_rate/minstrel/minstrel.c
++++ b/ath_rate/minstrel/minstrel.c
 @@ -117,7 +117,9 @@
  
  #include "minstrel.h"
@@ -129,10 +123,8 @@ Index: madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c
  #ifdef MINSTREL_DEBUG
  enum {
                ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-Index: madwifi-trunk-r3314/ath_rate/onoe/onoe.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/onoe/onoe.c      2008-03-07 01:45:09.426374706 +0100
-+++ madwifi-trunk-r3314/ath_rate/onoe/onoe.c   2008-03-07 01:47:43.205511589 +0100
+--- a/ath_rate/onoe/onoe.c
++++ b/ath_rate/onoe/onoe.c
 @@ -66,7 +66,9 @@
  
  #include "onoe.h"
@@ -143,10 +135,8 @@ Index: madwifi-trunk-r3314/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-Index: madwifi-trunk-r3314/ath_rate/sample/sample.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath_rate/sample/sample.c  2008-03-07 01:45:09.434375158 +0100
-+++ madwifi-trunk-r3314/ath_rate/sample/sample.c       2008-03-07 01:47:43.209509818 +0100
+--- a/ath_rate/sample/sample.c
++++ b/ath_rate/sample/sample.c
 @@ -68,7 +68,9 @@
  
  #include "sample.h"
@@ -158,11 +148,9 @@ Index: madwifi-trunk-r3314/ath_rate/sample/sample.c
  #ifdef SAMPLE_DEBUG
  enum {
        ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
-Index: madwifi-trunk-r3314/tools/do_multi.c
-===================================================================
---- madwifi-trunk-r3314.orig/tools/do_multi.c  2008-03-07 01:45:09.442375616 +0100
-+++ madwifi-trunk-r3314/tools/do_multi.c       2008-03-07 01:47:43.213508047 +0100
-@@ -9,16 +9,20 @@
+--- a/tools/do_multi.c
++++ b/tools/do_multi.c
+@@ -10,16 +10,20 @@
  
      progname = basename(argv[0]);
  
@@ -183,44 +171,28 @@ Index: madwifi-trunk-r3314/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-trunk-r3314/tools/Makefile
-===================================================================
---- madwifi-trunk-r3314.orig/tools/Makefile    2008-03-07 01:45:09.450376072 +0100
-+++ madwifi-trunk-r3314/tools/Makefile 2008-03-07 01:47:43.217506273 +0100
-@@ -46,9 +46,10 @@
- HAL=   $(TOP)/hal
- endif
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -48,6 +48,8 @@
  
-+DEBUG=-DAR_DEBUG
+ all: compile
  
++DEBUG = -DAR_DEBUG
++
  ALLPROGS=     athstats 80211stats athkey athchans athctrl \
--      athdebug 80211debug wlanconfig ath_info
-+      $(if $(DEBUG),80211debug athdebug) wlanconfig ath_info
+       athdebug 80211debug wlanconfig ath_info
  
- OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
- ALL=  ${OBJS} madwifi_multi
-@@ -57,7 +58,7 @@
+@@ -55,7 +57,7 @@
  
- INCS= -I. -I$(HAL) -I$(TOP) -I$(ATH_HAL)
+ INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
  CFLAGS=       -g -O2 -Wall
 -ALL_CFLAGS= $(CFLAGS) $(INCS)
 +ALL_CFLAGS= $(CFLAGS) $(INCS) $(DEBUG)
  LDFLAGS=
  
- all:  $(ALL)
-@@ -84,7 +85,7 @@
-       ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi: $(OBJS)
-       ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
--      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
-+      for i in $(ALLPROGS); do \
-       ln -s -f madwifi_multi $$i; \
-       done
-Index: madwifi-trunk-r3314/net80211/ieee80211_linux.h
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_linux.h        2008-03-07 01:45:09.458376527 +0100
-+++ madwifi-trunk-r3314/net80211/ieee80211_linux.h     2008-03-07 01:47:43.217506273 +0100
+--- a/net80211/ieee80211_linux.h
++++ b/net80211/ieee80211_linux.h
 @@ -29,8 +29,6 @@
  #ifndef _NET80211_IEEE80211_LINUX_H_
  #define _NET80211_IEEE80211_LINUX_H_
@@ -230,10 +202,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_linux.h
  /* #define ATH_DEBUG_SPINLOCKS */             /* announce before spinlocking */
  
  #include <linux/wireless.h>
-Index: madwifi-trunk-r3314/Makefile.inc
-===================================================================
---- madwifi-trunk-r3314.orig/Makefile.inc      2008-03-07 01:45:09.482377896 +0100
-+++ madwifi-trunk-r3314/Makefile.inc   2008-03-07 01:47:43.217506273 +0100
+--- a/Makefile.inc
++++ b/Makefile.inc
 @@ -148,7 +148,8 @@
  TOOLS=  $(TOP)/tools 
  
@@ -244,10 +214,8 @@ Index: madwifi-trunk-r3314/Makefile.inc
  INCS= -include $(TOP)/include/compat.h -I$(TOP)/include
  
  # TARGET defines the target platform architecture. It must match one of
-Index: madwifi-trunk-r3314/ath/if_ath_radar.c
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_radar.c        2008-03-07 01:45:09.386372426 +0100
-+++ madwifi-trunk-r3314/ath/if_ath_radar.c     2008-03-07 01:47:43.217506273 +0100
+--- a/ath/if_ath_radar.c
++++ b/ath/if_ath_radar.c
 @@ -19,8 +19,6 @@
   * $Id: if_ath_radar.c 2464 2007-06-15 22:51:56Z mtaylor $
   */
@@ -266,10 +234,8 @@ Index: madwifi-trunk-r3314/ath/if_ath_radar.c
  #include "net80211/if_athproto.h"
  #include "if_athvar.h"
  
-Index: madwifi-trunk-r3314/ath/if_ath_hal.h
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_hal.h  2008-03-07 01:45:09.394372879 +0100
-+++ madwifi-trunk-r3314/ath/if_ath_hal.h       2008-03-07 01:47:43.221504502 +0100
+--- a/ath/if_ath_hal.h
++++ b/ath/if_ath_hal.h
 @@ -1081,6 +1081,7 @@
  
             tail -f /var/log/messages | sed -f hal_unmangle.sed 
@@ -287,10 +253,8 @@ Index: madwifi-trunk-r3314/ath/if_ath_hal.h
  #include "if_ath_hal_wrappers.h"
  
  #endif                                /* #ifndef _IF_ATH_HAL_H_ */
-Index: madwifi-trunk-r3314/net80211/ieee80211_var.h
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_var.h  2008-03-07 01:45:09.466376986 +0100
-+++ madwifi-trunk-r3314/net80211/ieee80211_var.h       2008-03-07 01:47:43.221504502 +0100
+--- a/net80211/ieee80211_var.h
++++ b/net80211/ieee80211_var.h
 @@ -492,9 +492,10 @@
        /* inject a fake radar signal -- used while on a 802.11h DFS channels */
        unsigned int (*ic_test_radar)(struct ieee80211com *);
@@ -303,10 +267,8 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_var.h
        /* DFS channel availability check time (in seconds) */
        void (*ic_set_dfs_cac_time)(struct ieee80211com *, unsigned int);
        unsigned int (*ic_get_dfs_cac_time)(struct ieee80211com *);
-Index: madwifi-trunk-r3314/net80211/ieee80211_wireless.c
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_wireless.c     2008-03-07 01:45:09.474377438 +0100
-+++ madwifi-trunk-r3314/net80211/ieee80211_wireless.c  2008-03-07 01:47:43.225502730 +0100
+--- a/net80211/ieee80211_wireless.c
++++ b/net80211/ieee80211_wireless.c
 @@ -1548,6 +1548,7 @@
        return 0;
  }
@@ -345,11 +307,20 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_wireless.c
        set_priv(IEEE80211_IOCTL_ADDMAC, ieee80211_ioctl_addmac),
        set_priv(IEEE80211_IOCTL_DELMAC, ieee80211_ioctl_delmac),
        set_priv(IEEE80211_IOCTL_WDSADDMAC, ieee80211_ioctl_wdsmac),
-Index: madwifi-trunk-r3314/ath/if_ath_debug.h
-===================================================================
---- madwifi-trunk-r3314.orig/ath/if_ath_debug.h        2008-03-07 01:45:09.402373336 +0100
-+++ madwifi-trunk-r3314/ath/if_ath_debug.h     2008-03-07 01:47:43.225502730 +0100
-@@ -68,13 +68,6 @@
+--- a/ath/if_ath_debug.h
++++ b/ath/if_ath_debug.h
+@@ -54,6 +54,10 @@
+       ATH_DEBUG_GLOBAL        = (ATH_DEBUG_SKB|ATH_DEBUG_SKB_REF)
+ };
++#define       EPRINTF(_sc, _fmt, ...) \
++              printk(KERN_ERR "%s: %s: " _fmt, \
++                      SC_DEV_NAME(_sc), __func__, ## __VA_ARGS__)
++
+ #ifdef AR_DEBUG
+ /* DEBUG-ONLY DEFINITIONS */
+@@ -68,20 +72,9 @@
                ath_keyprint((_sc), __func__, _ix, _hk, _mac);          \
  } while (0)
  
@@ -363,7 +334,14 @@ Index: madwifi-trunk-r3314/ath/if_ath_debug.h
  
  #define       IFF_DUMPPKTS(_sc, _m)   DFLAG_ISSET((_sc), (_m))
  
-@@ -89,5 +82,15 @@
+-#define       EPRINTF(_sc, _fmt, ...) \
+-              printk(KERN_ERR "%s: %s: " _fmt, \
+-                      SC_DEV_NAME(_sc), __func__, ## __VA_ARGS__)
+-
+ #define       WPRINTF(_sc, _fmt, ...) \
+               printk(KERN_WARNING "%s: %s: " _fmt, \
+                       SC_DEV_NAME(_sc), __func__, ## __VA_ARGS__)
+@@ -89,5 +82,14 @@
  #define       IPRINTF(_sc, _fmt, ...) \
                printk(KERN_INFO "%s: %s: " _fmt, \
                        SC_DEV_NAME(_sc), __func__, ## __VA_ARGS__)
@@ -371,7 +349,6 @@ Index: madwifi-trunk-r3314/ath/if_ath_debug.h
 +#define       DFLAG_ISSET(sc, _m)             0
 +#define       DPRINTF(sc, _m, _fmt, ...)
 +#define       KEYPRINTF(sc, k, ix, mac)
-+#define EPRINTF(...)
 +#define WPRINTF(...)
 +#define IPRINTF(...)
 +#define IFF_DUMPPKTS(...) 0
@@ -379,10 +356,8 @@ Index: madwifi-trunk-r3314/ath/if_ath_debug.h
 +#endif
  
  #endif /* #ifndef _IF_ATH_DEBUG_H_ */
-Index: madwifi-trunk-r3314/net80211/ieee80211_node.c
-===================================================================
---- madwifi-trunk-r3314.orig/net80211/ieee80211_node.c 2008-03-07 01:49:21.741746524 +0100
-+++ madwifi-trunk-r3314/net80211/ieee80211_node.c      2008-03-07 01:50:03.856146488 +0100
+--- a/net80211/ieee80211_node.c
++++ b/net80211/ieee80211_node.c
 @@ -920,6 +920,9 @@
        ni->ni_rxkeyoff = 0;
  }
@@ -402,3 +377,29 @@ Index: madwifi-trunk-r3314/net80211/ieee80211_node.c
  
  static void
  #ifdef IEEE80211_DEBUG_REFCNT
+--- a/ath/if_ath_pci.c
++++ b/ath/if_ath_pci.c
+@@ -134,8 +134,10 @@
+       u16 vdevice;
+       int i;
+-      if (pci_enable_device(pdev))
++      if (pci_enable_device(pdev)) {
++              printk(KERN_ERR "%s: failed to enable PCI device\n", dev_info);
+               return -EIO;
++      }
+       /* XXX 32-bit addressing only */
+       if (pci_set_dma_mask(pdev, 0xffffffff)) {
+@@ -244,8 +246,10 @@
+               sc->aps_sc.sc_ledpin = 1;
+       }
+-      if (ath_attach(vdevice, dev, NULL) != 0)
++      if ((i = ath_attach(vdevice, dev, NULL)) != 0) {
++              printk(KERN_ERR "%s: ath_attach failed: %d\n", dev_info, i);
+               goto bad4;
++      }
+       athname = ath_hal_probe(id->vendor, vdevice);
+       printk(KERN_INFO "%s: %s: %s: mem=0x%lx, irq=%d\n",