refresh madwifi patches, fix an issue with napi polling (thx SeG)
[openwrt/openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index a54b33d529db6510598a1c23ed63569df66b0eaa..a37fd702f421208f8ff9e3a05b8d4b1c7fc75e04 100644 (file)
@@ -1,17 +1,16 @@
-Index: madwifi-dfs-r3053/ath/if_ath.c
+Index: madwifi-trunk-r3314/ath/if_ath.c
 ===================================================================
---- madwifi-dfs-r3053.orig/ath/if_ath.c        2007-12-13 05:25:13.122373270 +0100
-+++ madwifi-dfs-r3053/ath/if_ath.c     2007-12-13 05:25:13.342385808 +0100
-@@ -42,7 +42,7 @@
+--- madwifi-trunk-r3314.orig/ath/if_ath.c      2008-02-20 18:10:48.567282084 +0100
++++ madwifi-trunk-r3314/ath/if_ath.c   2008-02-20 18:10:48.783294393 +0100
+@@ -42,7 +42,6 @@
   * This software is derived from work of Atsushi Onoe; his contribution
   * is greatly appreciated.
   */
 -#define       AR_DEBUG
-+#undef        AR_DEBUG
  #include "if_ath_debug.h"
  #include "opt_ah.h"
  
-@@ -516,9 +516,11 @@
+@@ -520,9 +519,11 @@
        u_int8_t csz;
  
        sc->devid = devid;
@@ -21,9 +20,9 @@ Index: madwifi-dfs-r3053/ath/if_ath.c
        DPRINTF(sc, ATH_DEBUG_ANY, "%s: devid 0x%x\n", __func__, devid);
 +#endif
  
-       /*
-        * Cache line size is used to size and align various
-@@ -1280,12 +1282,14 @@
+       /* Allocate space for dynamically determined maximum VAP count */
+       sc->sc_bslot = 
+@@ -1297,12 +1298,14 @@
                /* If no default VAP debug flags are passed, allow a few to
                 * transfer down from the driver to new VAPs so we can have load
                 * time debugging for VAPs too. */
@@ -38,7 +37,7 @@ Index: madwifi-dfs-r3053/ath/if_ath.c
        }
        ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
  
-@@ -10308,9 +10312,11 @@
+@@ -10496,9 +10499,11 @@
                                /* XXX validate? */
                                sc->sc_ledpin = val;
                                break;
@@ -50,7 +49,7 @@ Index: madwifi-dfs-r3053/ath/if_ath.c
                                break;
                        case ATH_TXANTENNA:
                                /*
-@@ -10721,9 +10727,11 @@
+@@ -10918,9 +10923,11 @@
        }
  
        /* initialize values */
@@ -62,67 +61,72 @@ Index: madwifi-dfs-r3053/ath/if_ath.c
        sc->sc_txantenna = 0;           /* default to auto-selection */
        sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
  }
-Index: madwifi-dfs-r3053/ath_rate/amrr/amrr.c
+Index: madwifi-trunk-r3314/ath_rate/amrr/amrr.c
 ===================================================================
---- madwifi-dfs-r3053.orig/ath_rate/amrr/amrr.c        2007-12-13 05:25:10.422219395 +0100
-+++ madwifi-dfs-r3053/ath_rate/amrr/amrr.c     2007-12-13 05:25:13.342385808 +0100
-@@ -70,7 +70,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/amrr/amrr.c      2008-02-20 18:10:45.875128667 +0100
++++ madwifi-trunk-r3314/ath_rate/amrr/amrr.c   2008-02-20 18:10:48.787294621 +0100
+@@ -70,7 +70,9 @@
  
  #include "amrr.h"
  
--#define       AMRR_DEBUG
-+#undef        AMRR_DEBUG
++#ifdef AR_DEBUG
+ #define       AMRR_DEBUG
++#endif
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-Index: madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c
+Index: madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c
 ===================================================================
---- madwifi-dfs-r3053.orig/ath_rate/minstrel/minstrel.c        2007-12-13 05:25:12.006309667 +0100
-+++ madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c     2007-12-13 05:25:13.350386263 +0100
-@@ -117,7 +117,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/minstrel/minstrel.c      2008-02-20 18:10:47.471219622 +0100
++++ madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c   2008-02-20 18:10:48.795295077 +0100
+@@ -117,7 +117,9 @@
  
  #include "minstrel.h"
  
--#define       MINSTREL_DEBUG
-+#undef        MINSTREL_DEBUG
++#ifdef AR_DEBUG
+ #define       MINSTREL_DEBUG
++#endif
  #ifdef MINSTREL_DEBUG
  enum {
                ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-Index: madwifi-dfs-r3053/ath_rate/onoe/onoe.c
+Index: madwifi-trunk-r3314/ath_rate/onoe/onoe.c
 ===================================================================
---- madwifi-dfs-r3053.orig/ath_rate/onoe/onoe.c        2007-12-13 05:25:10.438220308 +0100
-+++ madwifi-dfs-r3053/ath_rate/onoe/onoe.c     2007-12-13 05:25:13.354386489 +0100
-@@ -66,7 +66,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/onoe/onoe.c      2008-02-20 18:10:45.891129578 +0100
++++ madwifi-trunk-r3314/ath_rate/onoe/onoe.c   2008-02-20 18:10:48.799295306 +0100
+@@ -66,7 +66,9 @@
  
  #include "onoe.h"
  
--#define       ONOE_DEBUG
-+#undef        ONOE_DEBUG
++#ifdef AR_DEBUG
+ #define       ONOE_DEBUG
++#endif
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-Index: madwifi-dfs-r3053/ath_rate/sample/sample.c
+Index: madwifi-trunk-r3314/ath_rate/sample/sample.c
 ===================================================================
---- madwifi-dfs-r3053.orig/ath_rate/sample/sample.c    2007-12-13 05:25:10.446220763 +0100
-+++ madwifi-dfs-r3053/ath_rate/sample/sample.c 2007-12-13 05:25:13.358386718 +0100
-@@ -68,7 +68,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/sample/sample.c  2008-02-20 18:10:45.899130036 +0100
++++ madwifi-trunk-r3314/ath_rate/sample/sample.c       2008-02-20 18:10:48.803295532 +0100
+@@ -68,7 +68,9 @@
  
  #include "sample.h"
  
 -#define       SAMPLE_DEBUG
-+#undef        SAMPLE_DEBUG
++#ifdef AR_DEBUG
++#define SAMPLE_DEBUG
++#endif
  #ifdef SAMPLE_DEBUG
  enum {
        ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
-Index: madwifi-dfs-r3053/tools/do_multi.c
+Index: madwifi-trunk-r3314/tools/do_multi.c
 ===================================================================
---- madwifi-dfs-r3053.orig/tools/do_multi.c    2007-12-13 05:25:11.242266126 +0100
-+++ madwifi-dfs-r3053/tools/do_multi.c 2007-12-13 05:25:13.362386947 +0100
+--- madwifi-trunk-r3314.orig/tools/do_multi.c  2008-02-20 18:10:46.711176309 +0100
++++ madwifi-trunk-r3314/tools/do_multi.c       2008-02-20 18:10:48.807295761 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
  
-+#if 0
++#ifdef AR_DEBUG
      if(strcmp(progname, "80211debug") == 0)
        ret = a80211debug_init(argc, argv);
 +#endif
@@ -132,47 +136,84 @@ Index: madwifi-dfs-r3053/tools/do_multi.c
        ret = athchans_init(argc, argv);
      if(strcmp(progname, "athctrl") == 0)
        ret =  athctrl_init(argc, argv);
-+#if 0
++#ifdef AR_DEBUG
      if(strcmp(progname, "athdebug") == 0)
        ret =  athdebug_init(argc, argv);
 +#endif
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-dfs-r3053/tools/Makefile
+Index: madwifi-trunk-r3314/tools/Makefile
 ===================================================================
---- madwifi-dfs-r3053.orig/tools/Makefile      2007-12-13 05:25:11.246266355 +0100
-+++ madwifi-dfs-r3053/tools/Makefile   2007-12-13 05:25:13.362386947 +0100
-@@ -48,7 +48,7 @@
+--- madwifi-trunk-r3314.orig/tools/Makefile    2008-02-20 18:10:46.715176538 +0100
++++ madwifi-trunk-r3314/tools/Makefile 2008-02-20 18:10:48.807295761 +0100
+@@ -46,9 +46,10 @@
+ HAL=   $(TOP)/hal
+ endif
  
++DEBUG=-DAR_DEBUG
  
  ALLPROGS=     athstats 80211stats athkey athchans athctrl \
 -      athdebug 80211debug wlanconfig ath_info
-+      wlanconfig ath_info
++      $(if $(DEBUG),80211debug athdebug) wlanconfig ath_info
  
  OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
  ALL=  ${OBJS} madwifi_multi
-@@ -84,7 +84,7 @@
+@@ -57,7 +58,7 @@
+ INCS= -I. -I$(HAL) -I$(TOP) -I$(ATH_HAL)
+ CFLAGS=       -g -O2 -Wall
+-ALL_CFLAGS= $(CFLAGS) $(INCS)
++ALL_CFLAGS= $(CFLAGS) $(INCS) $(DEBUG)
+ LDFLAGS=
+ all:  $(ALL)
+@@ -84,7 +85,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
  madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
-+      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
++      for i in $(ALLPROGS); do \
        ln -s -f madwifi_multi $$i; \
        done
  
-Index: madwifi-dfs-r3053/net80211/ieee80211_linux.h
+Index: madwifi-trunk-r3314/net80211/ieee80211_linux.h
 ===================================================================
---- madwifi-dfs-r3053.orig/net80211/ieee80211_linux.h  2007-12-13 05:25:10.470222132 +0100
-+++ madwifi-dfs-r3053/net80211/ieee80211_linux.h       2007-12-13 05:25:13.362386947 +0100
-@@ -29,8 +29,8 @@
+--- madwifi-trunk-r3314.orig/net80211/ieee80211_linux.h        2008-02-20 18:10:45.919131175 +0100
++++ madwifi-trunk-r3314/net80211/ieee80211_linux.h     2008-02-20 18:10:48.807295761 +0100
+@@ -29,8 +29,6 @@
  #ifndef _NET80211_IEEE80211_LINUX_H_
  #define _NET80211_IEEE80211_LINUX_H_
  
 -#define       IEEE80211_DEBUG
 -#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
-+#undef        IEEE80211_DEBUG
-+#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
  /* #define ATH_DEBUG_SPINLOCKS */             /* announce before spinlocking */
  
  #include <linux/wireless.h>
+Index: madwifi-trunk-r3314/Makefile.inc
+===================================================================
+--- madwifi-trunk-r3314.orig/Makefile.inc      2008-02-20 18:10:45.927131631 +0100
++++ madwifi-trunk-r3314/Makefile.inc   2008-02-20 18:10:48.807295761 +0100
+@@ -148,7 +148,8 @@
+ TOOLS=  $(TOP)/tools 
+ WARNINGS = -Werror
+-COPTS+= $(WARNINGS)
++DEBUG = -DAR_DEBUG -DIEEE80211_DEBUG
++COPTS+= $(WARNINGS) $(DEBUG)
+ INCS= -include $(TOP)/include/compat.h -I$(TOP)/include
+ # TARGET defines the target platform architecture. It must match one of
+Index: madwifi-trunk-r3314/ath/if_ath_radar.c
+===================================================================
+--- madwifi-trunk-r3314.orig/ath/if_ath_radar.c        2008-02-20 18:10:48.307267266 +0100
++++ madwifi-trunk-r3314/ath/if_ath_radar.c     2008-02-20 18:10:48.811295991 +0100
+@@ -19,8 +19,6 @@
+  * $Id: if_ath_radar.c 2464 2007-06-15 22:51:56Z mtaylor $
+  */
+ #include "opt_ah.h"
+-
+-#define       AR_DEBUG
+ #include "if_ath_debug.h"
+ #ifndef AUTOCONF_INCLUDED