refresh madwifi patches, fix an issue with napi polling (thx SeG)
[openwrt/openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index b1830c66d2518008d63a93d132b5c4a49a09a7f7..a37fd702f421208f8ff9e3a05b8d4b1c7fc75e04 100644 (file)
-Index: madwifi-ng-r2568-20070710/ath/if_ath.c
+Index: madwifi-trunk-r3314/ath/if_ath.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath/if_ath.c        2007-07-23 01:48:43.942484311 +0200
-+++ madwifi-ng-r2568-20070710/ath/if_ath.c     2007-07-23 01:48:44.466514171 +0200
-@@ -75,7 +75,7 @@
- #include <net80211/if_llc.h>
- #endif
+--- madwifi-trunk-r3314.orig/ath/if_ath.c      2008-02-20 18:10:48.567282084 +0100
++++ madwifi-trunk-r3314/ath/if_ath.c   2008-02-20 18:10:48.783294393 +0100
+@@ -42,7 +42,6 @@
+  * This software is derived from work of Atsushi Onoe; his contribution
+  * is greatly appreciated.
+  */
 -#define       AR_DEBUG
-+#undef        AR_DEBUG
+ #include "if_ath_debug.h"
+ #include "opt_ah.h"
+@@ -520,9 +519,11 @@
+       u_int8_t csz;
  
- #include "net80211/if_athproto.h"
- #include "if_athvar.h"
-Index: madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c
+       sc->devid = devid;
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       DPRINTF(sc, ATH_DEBUG_ANY, "%s: devid 0x%x\n", __func__, devid);
++#endif
+       /* Allocate space for dynamically determined maximum VAP count */
+       sc->sc_bslot = 
+@@ -1297,12 +1298,14 @@
+               /* If no default VAP debug flags are passed, allow a few to
+                * transfer down from the driver to new VAPs so we can have load
+                * time debugging for VAPs too. */
++#ifdef AR_DEBUG
+               vap->iv_debug = 0 |
+                       ((sc->sc_debug & ATH_DEBUG_RATE) ? IEEE80211_MSG_XRATE  : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_XMIT) ? IEEE80211_MSG_OUTPUT : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_RECV) ? IEEE80211_MSG_INPUT  : 0) |
+                       0
+                       ;
++#endif
+       }
+       ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
+@@ -10496,9 +10499,11 @@
+                               /* XXX validate? */
+                               sc->sc_ledpin = val;
+                               break;
++#ifdef AR_DEBUG
+                       case ATH_DEBUG:
+                               sc->sc_debug     = (val & ~ATH_DEBUG_GLOBAL);
+                               ath_debug_global = (val &  ATH_DEBUG_GLOBAL);
++#endif
+                               break;
+                       case ATH_TXANTENNA:
+                               /*
+@@ -10918,9 +10923,11 @@
+       }
+       /* initialize values */
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       sc->sc_default_ieee80211_debug = ieee80211_debug;
++#endif
+       sc->sc_txantenna = 0;           /* default to auto-selection */
+       sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
+ }
+Index: madwifi-trunk-r3314/ath_rate/amrr/amrr.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/amrr/amrr.c        2007-07-23 01:48:37.298105667 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c     2007-07-23 01:48:44.470514400 +0200
-@@ -70,7 +70,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/amrr/amrr.c      2008-02-20 18:10:45.875128667 +0100
++++ madwifi-trunk-r3314/ath_rate/amrr/amrr.c   2008-02-20 18:10:48.787294621 +0100
+@@ -70,7 +70,9 @@
  
  #include "amrr.h"
  
--#define       AMRR_DEBUG
-+#undef        AMRR_DEBUG
++#ifdef AR_DEBUG
+ #define       AMRR_DEBUG
++#endif
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-Index: madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c
+Index: madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/minstrel/minstrel.c        2007-07-23 01:48:40.974315165 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c     2007-07-23 01:48:44.494515770 +0200
-@@ -117,7 +117,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/minstrel/minstrel.c      2008-02-20 18:10:47.471219622 +0100
++++ madwifi-trunk-r3314/ath_rate/minstrel/minstrel.c   2008-02-20 18:10:48.795295077 +0100
+@@ -117,7 +117,9 @@
  
  #include "minstrel.h"
  
--#define       MINSTREL_DEBUG
-+#undef        MINSTREL_DEBUG
++#ifdef AR_DEBUG
+ #define       MINSTREL_DEBUG
++#endif
  #ifdef MINSTREL_DEBUG
  enum {
                ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-Index: madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c
+Index: madwifi-trunk-r3314/ath_rate/onoe/onoe.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/onoe/onoe.c        2007-07-23 01:48:37.314106578 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c     2007-07-23 01:48:44.518517136 +0200
-@@ -66,7 +66,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/onoe/onoe.c      2008-02-20 18:10:45.891129578 +0100
++++ madwifi-trunk-r3314/ath_rate/onoe/onoe.c   2008-02-20 18:10:48.799295306 +0100
+@@ -66,7 +66,9 @@
  
  #include "onoe.h"
  
--#define       ONOE_DEBUG
-+#undef        ONOE_DEBUG
++#ifdef AR_DEBUG
+ #define       ONOE_DEBUG
++#endif
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-Index: madwifi-ng-r2568-20070710/ath_rate/sample/sample.c
+Index: madwifi-trunk-r3314/ath_rate/sample/sample.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/ath_rate/sample/sample.c    2007-07-23 01:48:37.322107035 +0200
-+++ madwifi-ng-r2568-20070710/ath_rate/sample/sample.c 2007-07-23 01:48:44.546518731 +0200
-@@ -68,7 +68,7 @@
+--- madwifi-trunk-r3314.orig/ath_rate/sample/sample.c  2008-02-20 18:10:45.899130036 +0100
++++ madwifi-trunk-r3314/ath_rate/sample/sample.c       2008-02-20 18:10:48.803295532 +0100
+@@ -68,7 +68,9 @@
  
  #include "sample.h"
  
 -#define       SAMPLE_DEBUG
-+#undef        SAMPLE_DEBUG
++#ifdef AR_DEBUG
++#define SAMPLE_DEBUG
++#endif
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_NODE          = 0x00080000,   /* node management */
-Index: madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c
+       ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
+Index: madwifi-trunk-r3314/tools/do_multi.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_proto.c  2007-07-23 01:48:37.330107492 +0200
-+++ madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c       2007-07-23 01:48:44.570520097 +0200
-@@ -286,6 +286,7 @@
- }
- EXPORT_SYMBOL(ieee80211_aclator_get);
-+#ifdef IEEE80211_DEBUG
- void
- ieee80211_print_essid(const u_int8_t *essid, int len)
- {
-@@ -312,7 +313,6 @@
- }
- EXPORT_SYMBOL(ieee80211_print_essid);
--#ifdef IEEE80211_DEBUG
- void
- ieee80211_dump_pkt(struct ieee80211com *ic,
-       const u_int8_t *buf, int len, int rate, int rssi)
-Index: madwifi-ng-r2568-20070710/net80211/ieee80211_var.h
-===================================================================
---- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_var.h    2007-07-23 01:48:37.338107946 +0200
-+++ madwifi-ng-r2568-20070710/net80211/ieee80211_var.h 2007-07-23 01:48:44.622523064 +0200
-@@ -35,8 +35,8 @@
- #ifndef _NET80211_IEEE80211_VAR_H_
- #define _NET80211_IEEE80211_VAR_H_
--#define       IEEE80211_DEBUG
--#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
-+#undef        IEEE80211_DEBUG
-+#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
- /* Definitions for IEEE 802.11 drivers. */
- #include <net80211/ieee80211_linux.h>
-Index: madwifi-ng-r2568-20070710/tools/do_multi.c
-===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/do_multi.c    2007-07-23 01:48:39.754245634 +0200
-+++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-23 01:48:44.650524656 +0200
+--- madwifi-trunk-r3314.orig/tools/do_multi.c  2008-02-20 18:10:46.711176309 +0100
++++ madwifi-trunk-r3314/tools/do_multi.c       2008-02-20 18:10:48.807295761 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
  
-+#if 0
++#ifdef AR_DEBUG
      if(strcmp(progname, "80211debug") == 0)
        ret = a80211debug_init(argc, argv);
 +#endif
@@ -116,32 +136,84 @@ Index: madwifi-ng-r2568-20070710/tools/do_multi.c
        ret = athchans_init(argc, argv);
      if(strcmp(progname, "athctrl") == 0)
        ret =  athctrl_init(argc, argv);
-+#if 0
++#ifdef AR_DEBUG
      if(strcmp(progname, "athdebug") == 0)
        ret =  athdebug_init(argc, argv);
 +#endif
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-ng-r2568-20070710/tools/Makefile
+Index: madwifi-trunk-r3314/tools/Makefile
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-23 01:48:39.798248141 +0200
-+++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-23 01:48:44.670525796 +0200
-@@ -52,7 +52,7 @@
-       
- ifdef DOMULTI
- OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
--      athdebug.o 80211debug.o wlanconfig.o
-+      wlanconfig.o
- ALL=  ${OBJS} madwifi_multi
+--- madwifi-trunk-r3314.orig/tools/Makefile    2008-02-20 18:10:46.715176538 +0100
++++ madwifi-trunk-r3314/tools/Makefile 2008-02-20 18:10:48.807295761 +0100
+@@ -46,9 +46,10 @@
+ HAL=   $(TOP)/hal
  endif
  
-@@ -85,7 +85,7 @@
++DEBUG=-DAR_DEBUG
+ ALLPROGS=     athstats 80211stats athkey athchans athctrl \
+-      athdebug 80211debug wlanconfig ath_info
++      $(if $(DEBUG),80211debug athdebug) wlanconfig ath_info
+ OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
+ ALL=  ${OBJS} madwifi_multi
+@@ -57,7 +58,7 @@
+ INCS= -I. -I$(HAL) -I$(TOP) -I$(ATH_HAL)
+ CFLAGS=       -g -O2 -Wall
+-ALL_CFLAGS= $(CFLAGS) $(INCS)
++ALL_CFLAGS= $(CFLAGS) $(INCS) $(DEBUG)
+ LDFLAGS=
+ all:  $(ALL)
+@@ -84,7 +85,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi:
+ madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
-+      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
++      for i in $(ALLPROGS); do \
        ln -s -f madwifi_multi $$i; \
        done
  
+Index: madwifi-trunk-r3314/net80211/ieee80211_linux.h
+===================================================================
+--- madwifi-trunk-r3314.orig/net80211/ieee80211_linux.h        2008-02-20 18:10:45.919131175 +0100
++++ madwifi-trunk-r3314/net80211/ieee80211_linux.h     2008-02-20 18:10:48.807295761 +0100
+@@ -29,8 +29,6 @@
+ #ifndef _NET80211_IEEE80211_LINUX_H_
+ #define _NET80211_IEEE80211_LINUX_H_
+-#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
+ /* #define ATH_DEBUG_SPINLOCKS */             /* announce before spinlocking */
+ #include <linux/wireless.h>
+Index: madwifi-trunk-r3314/Makefile.inc
+===================================================================
+--- madwifi-trunk-r3314.orig/Makefile.inc      2008-02-20 18:10:45.927131631 +0100
++++ madwifi-trunk-r3314/Makefile.inc   2008-02-20 18:10:48.807295761 +0100
+@@ -148,7 +148,8 @@
+ TOOLS=  $(TOP)/tools 
+ WARNINGS = -Werror
+-COPTS+= $(WARNINGS)
++DEBUG = -DAR_DEBUG -DIEEE80211_DEBUG
++COPTS+= $(WARNINGS) $(DEBUG)
+ INCS= -include $(TOP)/include/compat.h -I$(TOP)/include
+ # TARGET defines the target platform architecture. It must match one of
+Index: madwifi-trunk-r3314/ath/if_ath_radar.c
+===================================================================
+--- madwifi-trunk-r3314.orig/ath/if_ath_radar.c        2008-02-20 18:10:48.307267266 +0100
++++ madwifi-trunk-r3314/ath/if_ath_radar.c     2008-02-20 18:10:48.811295991 +0100
+@@ -19,8 +19,6 @@
+  * $Id: if_ath_radar.c 2464 2007-06-15 22:51:56Z mtaylor $
+  */
+ #include "opt_ah.h"
+-
+-#define       AR_DEBUG
+ #include "if_ath_debug.h"
+ #ifndef AUTOCONF_INCLUDED