hostapd: update to version 2021-05-21
[openwrt/openwrt.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index 96ac4f92da331a842612494307bede8d3d2532dc..013b81d25be10ed61cdee3700efbe8a998b27442 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -105,6 +105,11 @@ OBJS += ../src/common/wpa_common.o
+@@ -166,6 +166,11 @@ OBJS += ../src/common/hw_features_common
  
  OBJS += ../src/eapol_auth/eapol_auth_sm.o
  
 +LIBS += -lubox -lubus
 +endif
  
- ifndef CONFIG_NO_DUMP_STATE
- # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
+ ifdef CONFIG_CODE_COVERAGE
+ CFLAGS += -O0 -fprofile-arcs -ftest-coverage
 --- a/src/ap/hostapd.h
 +++ b/src/ap/hostapd.h
-@@ -11,6 +11,7 @@
- #include "common/defs.h"
+@@ -17,6 +17,7 @@
+ #include "utils/list.h"
  #include "ap_config.h"
+ #include "drivers/driver.h"
 +#include "ubus.h"
  
- struct wpa_driver_ops;
- struct wpa_ctrl_dst;
-@@ -105,6 +106,7 @@ struct hostapd_data {
+ #define OCE_STA_CFON_ENABLED(hapd) \
+       ((hapd->conf->oce & OCE_STA_CFON) && \
+@@ -80,7 +81,7 @@ struct hapd_interfaces {
+ #ifdef CONFIG_CTRL_IFACE_UDP
+        unsigned char ctrl_iface_cookie[CTRL_IFACE_COOKIE_LEN];
+ #endif /* CONFIG_CTRL_IFACE_UDP */
+-
++      struct ubus_object ubus;
+ };
+ enum hostapd_chan_status {
+@@ -154,6 +155,7 @@ struct hostapd_data {
        struct hostapd_iface *iface;
        struct hostapd_config *iconf;
        struct hostapd_bss_config *conf;
 +      struct hostapd_ubus_bss ubus;
        int interface_added; /* virtual interface added for this BSS */
        unsigned int started:1;
-@@ -256,6 +258,8 @@ struct hostapd_iface {
-       struct hostapd_config *conf;
-       char phy[16]; /* Name of the PHY (radio) */
-+      struct hostapd_ubus_iface ubus;
-+
-       enum hostapd_iface_state {
-               HAPD_IFACE_UNINITIALIZED,
-               HAPD_IFACE_DISABLED,
---- /dev/null
-+++ b/src/ap/ubus.c
-@@ -0,0 +1,373 @@
-+/*
-+ * hostapd / ubus support
-+ * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
-+ *
-+ * This software may be distributed under the terms of the BSD license.
-+ * See README for more details.
-+ */
-+
-+#include "utils/includes.h"
-+#include "utils/common.h"
-+#include "utils/eloop.h"
-+#include "common/ieee802_11_defs.h"
-+#include "hostapd.h"
-+#include "sta_info.h"
-+#include "ubus.h"
-+
-+static struct ubus_context *ctx;
-+static struct blob_buf b;
-+static int ctx_ref;
-+
-+struct ubus_banned_client {
-+      struct avl_node avl;
-+      u8 addr[ETH_ALEN];
-+};
-+
-+static void ubus_receive(int sock, void *eloop_ctx, void *sock_ctx)
-+{
-+      struct ubus_context *ctx = eloop_ctx;
-+      ubus_handle_event(ctx);
-+}
-+
-+static void ubus_reconnect_timeout(void *eloop_data, void *user_ctx)
-+{
-+      if (ubus_reconnect(ctx, NULL)) {
-+              eloop_register_timeout(1, 0, ubus_reconnect_timeout, ctx, NULL);
-+              return;
-+      }
-+
-+      eloop_register_read_sock(ctx->sock.fd, ubus_receive, ctx, NULL);
-+}
-+
-+static void hostapd_ubus_connection_lost(struct ubus_context *ctx)
-+{
-+      eloop_unregister_read_sock(ctx->sock.fd);
-+      eloop_register_timeout(1, 0, ubus_reconnect_timeout, ctx, NULL);
-+}
-+
-+static bool hostapd_ubus_init(void)
-+{
-+      if (ctx)
-+              return true;
-+
-+      ctx = ubus_connect(NULL);
-+      if (!ctx)
-+              return false;
-+
-+      ctx->connection_lost = hostapd_ubus_connection_lost;
-+      eloop_register_read_sock(ctx->sock.fd, ubus_receive, ctx, NULL);
-+      return true;
-+}
-+
-+static void hostapd_ubus_ref_inc(void)
-+{
-+      ctx_ref++;
-+}
-+
-+static void hostapd_ubus_ref_dec(void)
-+{
-+      ctx_ref--;
-+      if (!ctx)
-+              return;
-+
-+      if (ctx_ref)
-+              return;
-+
-+      eloop_unregister_read_sock(ctx->sock.fd);
-+      ubus_free(ctx);
-+      ctx = NULL;
-+}
-+
-+void hostapd_ubus_add_iface(struct hostapd_iface *iface)
-+{
-+      if (!hostapd_ubus_init())
-+              return;
-+}
-+
-+void hostapd_ubus_free_iface(struct hostapd_iface *iface)
-+{
-+      if (!ctx)
-+              return;
-+}
-+
-+static void
-+hostapd_bss_del_ban(void *eloop_data, void *user_ctx)
-+{
-+      struct ubus_banned_client *ban = eloop_data;
-+      struct hostapd_data *hapd = user_ctx;
-+
-+      avl_delete(&hapd->ubus.banned, &ban->avl);
-+      free(ban);
-+}
-+
-+static void
-+hostapd_bss_ban_client(struct hostapd_data *hapd, u8 *addr, int time)
-+{
-+      struct ubus_banned_client *ban;
-+
-+      if (time < 0)
-+              time = 0;
-+
-+      ban = avl_find_element(&hapd->ubus.banned, addr, ban, avl);
-+      if (!ban) {
-+              if (!time)
-+                      return;
-+
-+              ban = os_zalloc(sizeof(*ban));
-+              memcpy(ban->addr, addr, sizeof(ban->addr));
-+              ban->avl.key = ban->addr;
-+              avl_insert(&hapd->ubus.banned, &ban->avl);
-+      } else {
-+              eloop_cancel_timeout(hostapd_bss_del_ban, ban, hapd);
-+              if (!time) {
-+                      hostapd_bss_del_ban(ban, hapd);
-+                      return;
-+              }
-+      }
-+
-+      eloop_register_timeout(0, time * 1000, hostapd_bss_del_ban, ban, hapd);
-+}
-+
-+static int
-+hostapd_bss_get_clients(struct ubus_context *ctx, struct ubus_object *obj,
-+                      struct ubus_request_data *req, const char *method,
-+                      struct blob_attr *msg)
-+{
-+      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
-+      struct sta_info *sta;
-+      void *list, *c;
-+      char mac_buf[20];
-+      static const struct {
-+              const char *name;
-+              uint32_t flag;
-+      } sta_flags[] = {
-+              { "auth", WLAN_STA_AUTH },
-+              { "assoc", WLAN_STA_ASSOC },
-+              { "authorized", WLAN_STA_AUTHORIZED },
-+              { "preauth", WLAN_STA_PREAUTH },
-+              { "wds", WLAN_STA_WDS },
-+              { "wmm", WLAN_STA_WMM },
-+              { "ht", WLAN_STA_HT },
-+              { "vht", WLAN_STA_VHT },
-+              { "wps", WLAN_STA_WPS },
-+              { "mfp", WLAN_STA_MFP },
-+      };
-+
-+      blob_buf_init(&b, 0);
-+      blobmsg_add_u32(&b, "freq", hapd->iface->freq);
-+      list = blobmsg_open_table(&b, "clients");
-+      for (sta = hapd->sta_list; sta; sta = sta->next) {
-+              int i;
-+
-+              sprintf(mac_buf, MACSTR, MAC2STR(sta->addr));
-+              c = blobmsg_open_table(&b, mac_buf);
-+              for (i = 0; i < ARRAY_SIZE(sta_flags); i++)
-+                      blobmsg_add_u8(&b, sta_flags[i].name,
-+                                     !!(sta->flags & sta_flags[i].flag));
-+              blobmsg_add_u32(&b, "aid", sta->aid);
-+              blobmsg_close_table(&b, c);
-+      }
-+      blobmsg_close_array(&b, list);
-+      ubus_send_reply(ctx, req, b.head);
-+
-+      return 0;
-+}
-+
-+enum {
-+      DEL_CLIENT_ADDR,
-+      DEL_CLIENT_REASON,
-+      DEL_CLIENT_DEAUTH,
-+      DEL_CLIENT_BAN_TIME,
-+      __DEL_CLIENT_MAX
-+};
-+
-+static const struct blobmsg_policy del_policy[__DEL_CLIENT_MAX] = {
-+      [DEL_CLIENT_ADDR] = { "addr", BLOBMSG_TYPE_STRING },
-+      [DEL_CLIENT_REASON] = { "reason", BLOBMSG_TYPE_INT32 },
-+      [DEL_CLIENT_DEAUTH] = { "deauth", BLOBMSG_TYPE_INT8 },
-+      [DEL_CLIENT_BAN_TIME] = { "ban_time", BLOBMSG_TYPE_INT32 },
-+};
-+
-+static int
-+hostapd_bss_del_client(struct ubus_context *ctx, struct ubus_object *obj,
-+                      struct ubus_request_data *req, const char *method,
-+                      struct blob_attr *msg)
-+{
-+      struct blob_attr *tb[__DEL_CLIENT_MAX];
-+      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
-+      struct sta_info *sta;
-+      bool deauth = false;
-+      int reason;
-+      u8 addr[ETH_ALEN];
-+
-+      blobmsg_parse(del_policy, __DEL_CLIENT_MAX, tb, blob_data(msg), blob_len(msg));
-+
-+      if (!tb[DEL_CLIENT_ADDR])
-+              return UBUS_STATUS_INVALID_ARGUMENT;
-+
-+      if (hwaddr_aton(blobmsg_data(tb[DEL_CLIENT_ADDR]), addr))
-+              return UBUS_STATUS_INVALID_ARGUMENT;
-+
-+      if (tb[DEL_CLIENT_REASON])
-+              reason = blobmsg_get_u32(tb[DEL_CLIENT_REASON]);
-+
-+      if (tb[DEL_CLIENT_DEAUTH])
-+              deauth = blobmsg_get_bool(tb[DEL_CLIENT_DEAUTH]);
-+
-+      sta = ap_get_sta(hapd, addr);
-+      if (sta) {
-+              if (deauth) {
-+                      hostapd_drv_sta_deauth(hapd, addr, reason);
-+                      ap_sta_deauthenticate(hapd, sta, reason);
-+              } else {
-+                      hostapd_drv_sta_disassoc(hapd, addr, reason);
-+                      ap_sta_disassociate(hapd, sta, reason);
-+              }
-+      }
-+
-+      if (tb[DEL_CLIENT_BAN_TIME])
-+              hostapd_bss_ban_client(hapd, addr, blobmsg_get_u32(tb[DEL_CLIENT_BAN_TIME]));
-+
-+      return 0;
-+}
-+
-+static void
-+blobmsg_add_macaddr(struct blob_buf *buf, const char *name, const u8 *addr)
-+{
-+      char *s;
-+
-+      s = blobmsg_alloc_string_buffer(buf, name, 20);
-+      sprintf(s, MACSTR, MAC2STR(addr));
-+      blobmsg_add_string_buffer(buf);
-+}
-+
-+static int
-+hostapd_bss_list_bans(struct ubus_context *ctx, struct ubus_object *obj,
-+                    struct ubus_request_data *req, const char *method,
-+                    struct blob_attr *msg)
-+{
-+      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
-+      struct ubus_banned_client *ban;
-+      void *c;
-+
-+      blob_buf_init(&b, 0);
-+      c = blobmsg_open_array(&b, "clients");
-+      avl_for_each_element(&hapd->ubus.banned, ban, avl)
-+              blobmsg_add_macaddr(&b, NULL, ban->addr);
-+      blobmsg_close_array(&b, c);
-+      ubus_send_reply(ctx, req, b.head);
-+
-+      return 0;
-+}
-+
-+static const struct ubus_method bss_methods[] = {
-+      UBUS_METHOD_NOARG("get_clients", hostapd_bss_get_clients),
-+      UBUS_METHOD("del_client", hostapd_bss_del_client, del_policy),
-+      UBUS_METHOD_NOARG("list_bans", hostapd_bss_list_bans),
-+};
-+
-+static struct ubus_object_type bss_object_type =
-+      UBUS_OBJECT_TYPE("hostapd_bss", bss_methods);
-+
-+static int avl_compare_macaddr(const void *k1, const void *k2, void *ptr)
-+{
-+      return memcmp(k1, k2, ETH_ALEN);
-+}
-+
-+void hostapd_ubus_add_bss(struct hostapd_data *hapd)
-+{
-+      struct ubus_object *obj = &hapd->ubus.obj;
-+      char *name;
-+      int ret;
-+
-+      if (!hostapd_ubus_init())
-+              return;
-+
-+      if (asprintf(&name, "hostapd.%s", hapd->conf->iface) < 0)
-+              return;
-+
-+      avl_init(&hapd->ubus.banned, avl_compare_macaddr, false, NULL);
-+      obj->name = name;
-+      obj->type = &bss_object_type;
-+      obj->methods = bss_object_type.methods;
-+      obj->n_methods = bss_object_type.n_methods;
-+      ret = ubus_add_object(ctx, obj);
-+      hostapd_ubus_ref_inc();
-+}
-+
-+void hostapd_ubus_free_bss(struct hostapd_data *hapd)
-+{
-+      struct ubus_object *obj = &hapd->ubus.obj;
-+      char *name = (char *) obj->name;
-+
-+      if (!ctx)
-+              return;
-+
-+      if (obj->id) {
-+              ubus_remove_object(ctx, obj);
-+              hostapd_ubus_ref_dec();
-+      }
-+
-+      free(name);
-+}
-+
-+struct ubus_event_req {
-+      struct ubus_notify_request nreq;
-+      bool deny;
-+};
-+
-+static void
-+ubus_event_cb(struct ubus_notify_request *req, int idx, int ret)
-+{
-+      struct ubus_event_req *ureq = container_of(req, struct ubus_event_req, nreq);
-+
-+      if (ret)
-+              ureq->deny = true;
-+}
-+
-+int hostapd_ubus_handle_event(struct hostapd_data *hapd, struct hostapd_ubus_request *req)
-+{
-+      struct ubus_banned_client *ban;
-+      const char *types[HOSTAPD_UBUS_TYPE_MAX] = {
-+              [HOSTAPD_UBUS_PROBE_REQ] = "probe",
-+              [HOSTAPD_UBUS_AUTH_REQ] = "auth",
-+              [HOSTAPD_UBUS_ASSOC_REQ] = "assoc",
-+      };
-+      const char *type = "mgmt";
-+      struct ubus_event_req ureq = {};
-+      const u8 *addr;
-+
-+      if (req->mgmt_frame)
-+              addr = req->mgmt_frame->sa;
-+      else
-+              addr = req->addr;
-+
-+      ban = avl_find_element(&hapd->ubus.banned, addr, ban, avl);
-+      if (ban)
-+              return -2;
-+
-+      if (!hapd->ubus.obj.has_subscribers)
-+              return 0;
-+
-+      if (req->type < ARRAY_SIZE(types))
-+              type = types[req->type];
-+
-+      blob_buf_init(&b, 0);
-+      blobmsg_add_macaddr(&b, "address", addr);
-+      if (req->mgmt_frame)
-+              blobmsg_add_macaddr(&b, "target", req->mgmt_frame->da);
-+      if (req->frame_info)
-+              blobmsg_add_u32(&b, "signal", req->frame_info->ssi_signal);
-+      blobmsg_add_u32(&b, "freq", hapd->iface->freq);
-+
-+      if (ubus_notify_async(ctx, &hapd->ubus.obj, type, b.head, &ureq.nreq))
-+              return 0;
-+
-+      ureq.nreq.status_cb = ubus_event_cb;
-+      ubus_complete_request(ctx, &ureq.nreq.req, 100);
-+
-+      if (ureq.deny)
-+              return -1;
-+
-+      return 0;
-+}
---- /dev/null
-+++ b/src/ap/ubus.h
-@@ -0,0 +1,78 @@
-+/*
-+ * hostapd / ubus support
-+ * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
-+ *
-+ * This software may be distributed under the terms of the BSD license.
-+ * See README for more details.
-+ */
-+#ifndef __HOSTAPD_UBUS_H
-+#define __HOSTAPD_UBUS_H
-+
-+enum hostapd_ubus_event_type {
-+      HOSTAPD_UBUS_PROBE_REQ,
-+      HOSTAPD_UBUS_AUTH_REQ,
-+      HOSTAPD_UBUS_ASSOC_REQ,
-+      HOSTAPD_UBUS_TYPE_MAX
-+};
-+
-+struct hostapd_ubus_request {
-+      enum hostapd_ubus_event_type type;
-+      const struct ieee80211_mgmt *mgmt_frame;
-+      const struct hostapd_frame_info *frame_info;
-+      const u8 *addr;
-+};
-+
-+struct hostapd_iface;
-+struct hostapd_data;
-+
-+#ifdef UBUS_SUPPORT
-+
-+#include <libubox/avl.h>
-+#include <libubus.h>
-+
-+struct hostapd_ubus_iface {
-+      struct ubus_object obj;
-+};
-+
-+struct hostapd_ubus_bss {
-+      struct ubus_object obj;
-+      struct avl_tree banned;
-+};
-+
-+void hostapd_ubus_add_iface(struct hostapd_iface *iface);
-+void hostapd_ubus_free_iface(struct hostapd_iface *iface);
-+void hostapd_ubus_add_bss(struct hostapd_data *hapd);
-+void hostapd_ubus_free_bss(struct hostapd_data *hapd);
-+
-+int hostapd_ubus_handle_event(struct hostapd_data *hapd, struct hostapd_ubus_request *req);
-+
-+#else
-+
-+struct hostapd_ubus_iface {};
-+
-+struct hostapd_ubus_bss {};
-+
-+static inline void hostapd_ubus_add_iface(struct hostapd_iface *iface)
-+{
-+}
-+
-+static inline void hostapd_ubus_free_iface(struct hostapd_iface *iface)
-+{
-+}
-+
-+static inline void hostapd_ubus_add_bss(struct hostapd_data *hapd)
-+{
-+}
-+
-+static inline void hostapd_ubus_free_bss(struct hostapd_data *hapd)
-+{
-+}
-+
-+static inline int hostapd_ubus_handle_event(struct hostapd_data *hapd, struct hostapd_ubus_request *req)
-+{
-+      return 0;
-+}
-+
-+#endif
-+
-+#endif
+       unsigned int disabled:1;
+@@ -610,6 +612,7 @@ hostapd_alloc_bss_data(struct hostapd_if
+                      struct hostapd_bss_config *bss);
+ int hostapd_setup_interface(struct hostapd_iface *iface);
+ int hostapd_setup_interface_complete(struct hostapd_iface *iface, int err);
++void hostapd_set_own_neighbor_report(struct hostapd_data *hapd);
+ void hostapd_interface_deinit(struct hostapd_iface *iface);
+ void hostapd_interface_free(struct hostapd_iface *iface);
+ struct hostapd_iface * hostapd_alloc_iface(void);
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -265,6 +265,7 @@ static void hostapd_free_hapd_data(struc
-       hapd->started = 0;
+@@ -396,6 +396,7 @@ void hostapd_free_hapd_data(struct hosta
+       hapd->beacon_set_done = 0;
  
        wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
 +      hostapd_ubus_free_bss(hapd);
-       iapp_deinit(hapd->iapp);
-       hapd->iapp = NULL;
        accounting_deinit(hapd);
-@@ -834,6 +835,8 @@ static int hostapd_setup_bss(struct host
+       hostapd_deinit_wpa(hapd);
+       vlan_deinit(hapd);
+@@ -1422,6 +1423,8 @@ static int hostapd_setup_bss(struct host
        if (hapd->driver && hapd->driver->set_operstate)
                hapd->driver->set_operstate(hapd->drv_priv, 1);
  
        return 0;
  }
  
-@@ -1108,6 +1111,7 @@ int hostapd_setup_interface_complete(str
+@@ -2028,6 +2031,7 @@ static int hostapd_setup_interface_compl
        if (err)
-               goto error;
+               goto fail;
  
 +      hostapd_ubus_add_iface(iface);
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
-       if (iface->conf->channel) {
+       if (iface->freq) {
  #ifdef NEED_AP_MLME
-@@ -1216,6 +1220,7 @@ int hostapd_setup_interface_complete(str
+@@ -2225,6 +2229,7 @@ dfs_offload:
  
error:
fail:
        wpa_printf(MSG_ERROR, "Interface initialization failed");
 +      hostapd_ubus_free_iface(iface);
        hostapd_set_state(iface, HAPD_IFACE_DISABLED);
-       if (iface->interfaces && iface->interfaces->terminate_on_error)
-               eloop_terminate();
-@@ -1537,6 +1542,7 @@ void hostapd_interface_deinit_free(struc
+       wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
+ #ifdef CONFIG_FST
+@@ -2700,6 +2705,7 @@ void hostapd_interface_deinit_free(struc
                   (unsigned int) iface->conf->num_bss);
        driver = iface->bss[0]->driver;
        drv_priv = iface->bss[0]->drv_priv;
                   __func__, driver, drv_priv);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
-@@ -535,7 +535,8 @@ static void handle_auth_sae(struct hosta
- static void handle_auth(struct hostapd_data *hapd,
--                      const struct ieee80211_mgmt *mgmt, size_t len)
-+                      const struct ieee80211_mgmt *mgmt, size_t len,
-+                      struct hostapd_frame_info *fi)
- {
+@@ -3553,13 +3553,18 @@ static void handle_auth(struct hostapd_d
        u16 auth_alg, auth_transaction, status_code;
        u16 resp = WLAN_STATUS_SUCCESS;
-@@ -550,6 +551,11 @@ static void handle_auth(struct hostapd_d
+       struct sta_info *sta = NULL;
+-      int res, reply_res;
++      int res, reply_res, ubus_resp;
+       u16 fc;
+       const u8 *challenge = NULL;
+       u8 resp_ies[2 + WLAN_AUTH_CHALLENGE_LEN];
        size_t resp_ies_len = 0;
-       char *identity = NULL;
-       char *radius_cui = NULL;
+       u16 seq_ctrl;
+       struct radius_sta rad_info;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_AUTH_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = rssi,
 +      };
  
        if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.auth)) {
                wpa_printf(MSG_INFO, "handle_auth - too short payload (len=%lu)",
-@@ -633,6 +639,14 @@ static void handle_auth(struct hostapd_d
+@@ -3727,6 +3732,13 @@ static void handle_auth(struct hostapd_d
                resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
                goto fail;
        }
-+
-+      if (hostapd_ubus_handle_event(hapd, &req)) {
++      ubus_resp = hostapd_ubus_handle_event(hapd, &req);
++      if (ubus_resp) {
 +              wpa_printf(MSG_DEBUG, "Station " MACSTR " rejected by ubus handler.\n",
-+                     MAC2STR(mgmt->sa));
-+              resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
++                      MAC2STR(mgmt->sa));
++              resp = ubus_resp > 0 ? (u16) ubus_resp : WLAN_STATUS_UNSPECIFIED_FAILURE;
 +              goto fail;
 +      }
-+
-       if (res == HOSTAPD_ACL_PENDING) {
-               wpa_printf(MSG_DEBUG, "Authentication frame from " MACSTR
-                          " waiting for an external authentication",
-@@ -1245,13 +1259,18 @@ static void send_assoc_resp(struct hosta
- static void handle_assoc(struct hostapd_data *hapd,
-                        const struct ieee80211_mgmt *mgmt, size_t len,
--                       int reassoc)
-+                       int reassoc, struct hostapd_frame_info *fi)
- {
-       u16 capab_info, listen_interval;
-       u16 resp = WLAN_STATUS_SUCCESS;
+       if (res == HOSTAPD_ACL_PENDING)
+               return;
+@@ -5446,7 +5458,7 @@ static void handle_assoc(struct hostapd_
+       int resp = WLAN_STATUS_SUCCESS;
+       u16 reply_res = WLAN_STATUS_UNSPECIFIED_FAILURE;
        const u8 *pos;
-       int left, i;
+-      int left, i;
++      int left, i, ubus_resp;
        struct sta_info *sta;
+       u8 *tmp = NULL;
+ #ifdef CONFIG_FILS
+@@ -5659,6 +5671,11 @@ static void handle_assoc(struct hostapd_
+               left = res;
+       }
+ #endif /* CONFIG_FILS */
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_ASSOC_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = rssi,
 +      };
  
-       if (len < IEEE80211_HDRLEN + (reassoc ? sizeof(mgmt->u.reassoc_req) :
-                                     sizeof(mgmt->u.assoc_req))) {
-@@ -1350,6 +1369,13 @@ static void handle_assoc(struct hostapd_
-               goto fail;
-       }
+       /* followed by SSID and Supported rates; and HT capabilities if 802.11n
+        * is used */
+@@ -5823,6 +5840,14 @@ static void handle_assoc(struct hostapd_
+                                           pos, left, rssi, omit_rsnxe);
+       os_free(tmp);
  
-+      if (hostapd_ubus_handle_event(hapd, &req)) {
++      ubus_resp = hostapd_ubus_handle_event(hapd, &req);
++      if (ubus_resp) {
 +              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
 +                     MAC2STR(mgmt->sa));
-+              resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
++              resp = ubus_resp > 0 ? (u16) ubus_resp : WLAN_STATUS_UNSPECIFIED_FAILURE;
 +              goto fail;
 +      }
 +
-       sta->capability = capab_info;
-       sta->listen_interval = listen_interval;
+       /*
+        * Remove the station in case transmission of a success response fails
+        * (the STA was added associated to the driver) or if the station was
+@@ -5850,6 +5875,7 @@ static void handle_disassoc(struct hosta
+       wpa_printf(MSG_DEBUG, "disassocation: STA=" MACSTR " reason_code=%d",
+                  MAC2STR(mgmt->sa),
+                  le_to_host16(mgmt->u.disassoc.reason_code));
++      hostapd_ubus_notify(hapd, "disassoc", mgmt->sa);
  
-@@ -1759,7 +1785,7 @@ void ieee802_11_mgmt(struct hostapd_data
+       sta = ap_get_sta(hapd, mgmt->sa);
+       if (sta == NULL) {
+@@ -5919,6 +5945,8 @@ static void handle_deauth(struct hostapd
+       /* Clear the PTKSA cache entries for PASN */
+       ptksa_cache_flush(hapd->ptksa, mgmt->sa, WPA_CIPHER_NONE);
  
-       if (stype == WLAN_FC_STYPE_PROBE_REQ) {
--              handle_probe_req(hapd, mgmt, len, fi->ssi_signal);
-+              handle_probe_req(hapd, mgmt, len, fi);
-               return;
-       }
-@@ -1774,15 +1800,15 @@ void ieee802_11_mgmt(struct hostapd_data
-       switch (stype) {
-       case WLAN_FC_STYPE_AUTH:
-               wpa_printf(MSG_DEBUG, "mgmt::auth");
--              handle_auth(hapd, mgmt, len);
-+              handle_auth(hapd, mgmt, len, fi);
-               break;
-       case WLAN_FC_STYPE_ASSOC_REQ:
-               wpa_printf(MSG_DEBUG, "mgmt::assoc_req");
--              handle_assoc(hapd, mgmt, len, 0);
-+              handle_assoc(hapd, mgmt, len, 0, fi);
-               break;
-       case WLAN_FC_STYPE_REASSOC_REQ:
-               wpa_printf(MSG_DEBUG, "mgmt::reassoc_req");
--              handle_assoc(hapd, mgmt, len, 1);
-+              handle_assoc(hapd, mgmt, len, 1, fi);
-               break;
-       case WLAN_FC_STYPE_DISASSOC:
-               wpa_printf(MSG_DEBUG, "mgmt::disassoc");
++      hostapd_ubus_notify(hapd, "deauth", mgmt->sa);
++
+       sta = ap_get_sta(hapd, mgmt->sa);
+       if (sta == NULL) {
+               wpa_msg(hapd->msg_ctx, MSG_DEBUG, "Station " MACSTR " trying "
 --- a/src/ap/beacon.c
 +++ b/src/ap/beacon.c
-@@ -398,7 +398,7 @@ static enum ssid_match_result ssid_match
- void handle_probe_req(struct hostapd_data *hapd,
-                     const struct ieee80211_mgmt *mgmt, size_t len,
--                    int ssi_signal)
-+                    struct hostapd_frame_info *fi)
- {
-       u8 *resp;
-       struct ieee802_11_elems elems;
-@@ -406,8 +406,14 @@ void handle_probe_req(struct hostapd_dat
-       size_t ie_len;
-       struct sta_info *sta = NULL;
-       size_t i, resp_len;
-+      int ssi_signal = fi->ssi_signal;
-       int noack;
-       enum ssid_match_result res;
+@@ -823,6 +823,12 @@ void handle_probe_req(struct hostapd_dat
+       u16 csa_offs[2];
+       size_t csa_offs_len;
+       struct radius_sta rad_info;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_PROBE_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = ssi_signal,
++              .elems = &elems,
 +      };
  
-       ie = mgmt->u.probe_req.variable;
-       if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.probe_req))
-@@ -546,6 +552,12 @@ void handle_probe_req(struct hostapd_dat
+       if (hapd->iconf->rssi_ignore_probe_request && ssi_signal &&
+           ssi_signal < hapd->iconf->rssi_ignore_probe_request)
+@@ -1009,6 +1015,12 @@ void handle_probe_req(struct hostapd_dat
        }
  #endif /* CONFIG_P2P */
  
        /* TODO: verify that supp_rates contains at least one matching rate
         * with AP configuration */
  
---- a/src/ap/beacon.h
-+++ b/src/ap/beacon.h
-@@ -20,7 +20,7 @@ struct ieee80211_mgmt;
- void handle_probe_req(struct hostapd_data *hapd,
-                     const struct ieee80211_mgmt *mgmt, size_t len,
--                    int ssi_signal);
-+                    struct hostapd_frame_info *fi);
- void ieee802_11_set_beacon(struct hostapd_data *hapd);
- void ieee802_11_set_beacons(struct hostapd_iface *iface);
- void ieee802_11_update_beacons(struct hostapd_iface *iface);
+--- a/src/ap/drv_callbacks.c
++++ b/src/ap/drv_callbacks.c
+@@ -145,6 +145,10 @@ int hostapd_notif_assoc(struct hostapd_d
+       u16 reason = WLAN_REASON_UNSPECIFIED;
+       int status = WLAN_STATUS_SUCCESS;
+       const u8 *p2p_dev_addr = NULL;
++      struct hostapd_ubus_request req = {
++              .type = HOSTAPD_UBUS_ASSOC_REQ,
++              .addr = addr,
++      };
+       if (addr == NULL) {
+               /*
+@@ -237,6 +241,12 @@ int hostapd_notif_assoc(struct hostapd_d
+               goto fail;
+       }
++      if (hostapd_ubus_handle_event(hapd, &req)) {
++              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
++                         MAC2STR(req.addr));
++              goto fail;
++      }
++
+ #ifdef CONFIG_P2P
+       if (elems.p2p) {
+               wpabuf_free(sta->p2p_ie);
+--- a/src/ap/sta_info.c
++++ b/src/ap/sta_info.c
+@@ -459,6 +459,7 @@ void ap_handle_timer(void *eloop_ctx, vo
+                              HOSTAPD_LEVEL_INFO, "deauthenticated due to "
+                              "local deauth request");
+               ap_free_sta(hapd, sta);
++              hostapd_ubus_notify(hapd, "local-deauth", sta->addr);
+               return;
+       }
+@@ -614,6 +615,7 @@ skip_poll:
+                       hapd, sta,
+                       WLAN_REASON_PREV_AUTH_NOT_VALID);
+               ap_free_sta(hapd, sta);
++              hostapd_ubus_notify(hapd, "inactive-deauth", sta->addr);
+               break;
+       }
+ }
+@@ -1329,6 +1331,7 @@ void ap_sta_set_authorized(struct hostap
+                                         buf, ip_addr, keyid_buf);
+       } else {
+               wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_DISCONNECTED "%s", buf);
++              hostapd_ubus_notify(hapd, "disassoc", sta->addr);
+               if (hapd->msg_ctx_parent &&
+                   hapd->msg_ctx_parent != hapd->msg_ctx)
+--- a/src/ap/wpa_auth_glue.c
++++ b/src/ap/wpa_auth_glue.c
+@@ -265,6 +265,7 @@ static void hostapd_wpa_auth_psk_failure
+       struct hostapd_data *hapd = ctx;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_POSSIBLE_PSK_MISMATCH MACSTR,
+               MAC2STR(addr));
++      hostapd_ubus_notify(hapd, "key-mismatch", addr);
+ }
+--- a/wpa_supplicant/Makefile
++++ b/wpa_supplicant/Makefile
+@@ -176,6 +176,12 @@ ifdef CONFIG_EAPOL_TEST
+ CFLAGS += -Werror -DEAPOL_TEST
+ endif
++ifdef CONFIG_UBUS
++CFLAGS += -DUBUS_SUPPORT
++OBJS += ubus.o
++LIBS += -lubox -lubus
++endif
++
+ ifdef CONFIG_CODE_COVERAGE
+ CFLAGS += -O0 -fprofile-arcs -ftest-coverage
+ LIBS += -lgcov
+@@ -959,6 +965,9 @@ ifdef CONFIG_CTRL_IFACE_MIB
+ CFLAGS += -DCONFIG_CTRL_IFACE_MIB
+ endif
+ OBJS += ../src/ap/ctrl_iface_ap.o
++ifdef CONFIG_UBUS
++OBJS += ../src/ap/ubus.o
++endif
+ endif
+ CFLAGS += -DEAP_SERVER -DEAP_SERVER_IDENTITY
+--- a/wpa_supplicant/wpa_supplicant.c
++++ b/wpa_supplicant/wpa_supplicant.c
+@@ -7017,6 +7017,8 @@ struct wpa_supplicant * wpa_supplicant_a
+       }
+ #endif /* CONFIG_P2P */
++      wpas_ubus_add_bss(wpa_s);
++
+       return wpa_s;
+ }
+@@ -7043,6 +7045,8 @@ int wpa_supplicant_remove_iface(struct w
+       struct wpa_supplicant *parent = wpa_s->parent;
+ #endif /* CONFIG_MESH */
++      wpas_ubus_free_bss(wpa_s);
++
+       /* Remove interface from the global list of interfaces */
+       prev = global->ifaces;
+       if (prev == wpa_s) {
+@@ -7346,8 +7350,12 @@ int wpa_supplicant_run(struct wpa_global
+       eloop_register_signal_terminate(wpa_supplicant_terminate, global);
+       eloop_register_signal_reconfig(wpa_supplicant_reconfig, global);
++      wpas_ubus_add(global);
++
+       eloop_run();
++      wpas_ubus_free(global);
++
+       return 0;
+ }
+--- a/wpa_supplicant/wpa_supplicant_i.h
++++ b/wpa_supplicant/wpa_supplicant_i.h
+@@ -19,6 +19,7 @@
+ #include "wps/wps_defs.h"
+ #include "config_ssid.h"
+ #include "wmm_ac.h"
++#include "ubus.h"
+ extern const char *const wpa_supplicant_version;
+ extern const char *const wpa_supplicant_license;
+@@ -321,6 +322,8 @@ struct wpa_global {
+ #endif /* CONFIG_WIFI_DISPLAY */
+       struct psk_list_entry *add_psk; /* From group formation */
++
++      struct ubus_object ubus_global;
+ };
+@@ -605,6 +608,7 @@ struct wpa_supplicant {
+       unsigned char own_addr[ETH_ALEN];
+       unsigned char perm_addr[ETH_ALEN];
+       char ifname[100];
++      struct wpas_ubus_bss ubus;
+ #ifdef CONFIG_MATCH_IFACE
+       int matched;
+ #endif /* CONFIG_MATCH_IFACE */
+--- a/wpa_supplicant/wps_supplicant.c
++++ b/wpa_supplicant/wps_supplicant.c
+@@ -33,6 +33,7 @@
+ #include "p2p/p2p.h"
+ #include "p2p_supplicant.h"
+ #include "wps_supplicant.h"
++#include "ubus.h"
+ #ifndef WPS_PIN_SCAN_IGNORE_SEL_REG
+@@ -392,6 +393,8 @@ static int wpa_supplicant_wps_cred(void
+       wpa_hexdump_key(MSG_DEBUG, "WPS: Received Credential attribute",
+                       cred->cred_attr, cred->cred_attr_len);
++      wpas_ubus_notify(wpa_s, cred);
++
+       if (wpa_s->conf->wps_cred_processing == 1)
+               return 0;
+--- a/hostapd/main.c
++++ b/hostapd/main.c
+@@ -895,6 +895,7 @@ int main(int argc, char *argv[])
+       }
+       hostapd_global_ctrl_iface_init(&interfaces);
++      hostapd_ubus_add(&interfaces);
+       if (hostapd_global_run(&interfaces, daemonize, pid_file)) {
+               wpa_printf(MSG_ERROR, "Failed to start eloop");
+@@ -904,6 +905,7 @@ int main(int argc, char *argv[])
+       ret = 0;
+  out:
++      hostapd_ubus_free(&interfaces);
+       hostapd_global_ctrl_iface_deinit(&interfaces);
+       /* Deinitialize all interfaces */
+       for (i = 0; i < interfaces.count; i++) {
+--- a/wpa_supplicant/main.c
++++ b/wpa_supplicant/main.c
+@@ -203,7 +203,7 @@ int main(int argc, char *argv[])
+       for (;;) {
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuv::W");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:nNo:O:p:P:qsTtuv::W");
+               if (c < 0)
+                       break;
+               switch (c) {
+@@ -271,6 +271,9 @@ int main(int argc, char *argv[])
+                       params.conf_p2p_dev = optarg;
+                       break;
+ #endif /* CONFIG_P2P */
++              case 'n':
++                      iface_count = 0;
++                      break;
+               case 'o':
+                       params.override_driver = optarg;
+                       break;
+--- a/src/ap/rrm.c
++++ b/src/ap/rrm.c
+@@ -89,6 +89,9 @@ static void hostapd_handle_beacon_report
+               return;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, BEACON_RESP_RX MACSTR " %u %02x %s",
+               MAC2STR(addr), token, rep_mode, report);
++      if (len < sizeof(struct rrm_measurement_beacon_report))
++              return;
++      hostapd_ubus_notify_beacon_report(hapd, addr, token, rep_mode, (struct rrm_measurement_beacon_report*) pos, len);
+ }
+--- a/src/ap/vlan_init.c
++++ b/src/ap/vlan_init.c
+@@ -22,6 +22,7 @@
+ static int vlan_if_add(struct hostapd_data *hapd, struct hostapd_vlan *vlan,
+                      int existsok)
+ {
++      bool vlan_exists = iface_exists(vlan->ifname);
+       int ret;
+ #ifdef CONFIG_WEP
+       int i;
+@@ -36,7 +37,7 @@ static int vlan_if_add(struct hostapd_da
+       }
+ #endif /* CONFIG_WEP */
+-      if (!iface_exists(vlan->ifname))
++      if (!vlan_exists)
+               ret = hostapd_vlan_if_add(hapd, vlan->ifname);
+       else if (!existsok)
+               return -1;
+@@ -51,6 +52,9 @@ static int vlan_if_add(struct hostapd_da
+       if (hapd->wpa_auth)
+               ret = wpa_auth_ensure_group(hapd->wpa_auth, vlan->vlan_id);
++      if (!ret && !vlan_exists)
++              hostapd_ubus_add_vlan(hapd, vlan);
++
+       if (ret == 0)
+               return ret;
+@@ -77,6 +81,8 @@ int vlan_if_remove(struct hostapd_data *
+                          "WPA deinitialization for VLAN %d failed (%d)",
+                          vlan->vlan_id, ret);
++      hostapd_ubus_remove_vlan(hapd, vlan);
++
+       return hostapd_vlan_if_remove(hapd, vlan->ifname);
+ }
+--- a/src/ap/dfs.c
++++ b/src/ap/dfs.c
+@@ -1193,6 +1193,8 @@ int hostapd_dfs_radar_detected(struct ho
+               "freq=%d ht_enabled=%d chan_offset=%d chan_width=%d cf1=%d cf2=%d",
+               freq, ht_enabled, chan_offset, chan_width, cf1, cf2);
++      hostapd_ubus_notify_radar_detected(iface, freq, chan_width, cf1, cf2);
++
+       /* Proceed only if DFS is not offloaded to the driver */
+       if (iface->drv_flags & WPA_DRIVER_FLAGS_DFS_OFFLOAD)
+               return 0;