iperf3: update to version 3.1.3
[openwrt/openwrt.git] / package / network / utils / iperf3 / Makefile
index 030c5f62b89193644208e7676fd1316bb0bb2d30..d68ac2bc6541813514aa6764b6ecf39fdb0c9bde 100644 (file)
@@ -8,15 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iperf
-PKG_VERSION:=3.0.11
+PKG_VERSION:=3.1.3
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.es.net/pub/iperf
-PKG_MD5SUM:=a3b2bed7961ba184566df3c3d47f96a6
+PKG_MD5SUM:=3fb849c24a2370af60687cf673b67bc7
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=BSD-3-Clause
 
 PKG_BUILD_PARALLEL:=1
@@ -28,9 +27,10 @@ define Package/iperf3
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Internet Protocol bandwidth measuring tool
-  URL:=http://sourceforge.net/projects/iperf/
+  URL:=https://github.com/esnet/iperf
 endef
 
+TARGET_CFLAGS += -D_GNU_SOURCE
 CONFIGURE_ARGS += --disable-shared
 
 MAKE_FLAGS += noinst_PROGRAMS=