ipq40xx: only include ath10k-board-qca4019 for the generic subtarget
[openwrt/staging/chunkeey.git] / package / network / utils / iproute2 / patches / 170-ip_tiny.patch
index 91240b6d2f4aa6c042f10775806157bde17bba94..cd687e760104462be127ef9d3787751e0c5e1114 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/Makefile
 +++ b/ip/Makefile
-@@ -16,6 +16,13 @@ RTMONOBJ=rtmon.o
+@@ -17,6 +17,13 @@ RTMONOBJ=rtmon.o
  
  include ../config.mk
  
@@ -14,7 +14,7 @@
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
-@@ -45,7 +52,7 @@ else
+@@ -46,7 +53,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -47,10 +47,16 @@ static void usage(void)
+@@ -64,11 +64,17 @@ static void usage(void)
        fprintf(stderr,
- "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
- "       ip [ -force ] -batch filename\n"
              "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
              "       ip [ -force ] -batch filename\n"
 +#ifndef IPROUTE2_TINY
- "where  OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n"
- "                   tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n"
- "                   netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n"
- "                   vrf | sr }\n"
+               "where  OBJECT := { address | addrlabel | fou | help | ila | ioam | l2tp | link |\n"
+               "                   macsec | maddress | monitor | mptcp | mroute | mrule |\n"
+               "                   neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
+               "                   ntbl | route | rule | sr | tap | tcpmetrics |\n"
+               "                   token | tunnel | tuntap | vrf | xfrm }\n"
 +#else
-+"where  OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n"
-+"                   mroute | mrule | monitor | netns | macsec | token | ila |\n"
-+"                   vrf | sr }\n"
++              "where  OBJECT := { address | ila | link | macsec | maddress | monitor |\n"
++              "                   mroute | mrule | neighbor | neighbour | netns | route |\n"
++              "                   rule | sr | token | tunnel | vrf }\n"
 +#endif
- "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
- "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
"                    -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
-@@ -72,32 +78,44 @@ static const struct cmd {
              "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
              "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
              "                    -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
+@@ -91,37 +97,51 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
 +#endif
        { "vrf",        do_ipvrf},
        { "sr",         do_seg6 },
-       { "help",       do_help },
---- a/lib/utils.c
-+++ b/lib/utils.c
-@@ -1000,6 +1000,7 @@ const char *rt_addr_n2a_r(int af, int le
-               return inet_ntop(af, addr, buf, buflen);
-       case AF_MPLS:
-               return mpls_ntop(af, addr, buf, buflen);
 +#ifndef IPROUTE2_TINY
-       case AF_IPX:
-               return ipx_ntop(af, addr, buf, buflen);
-       case AF_DECnet:
-@@ -1009,6 +1010,7 @@ const char *rt_addr_n2a_r(int af, int le
-               memcpy(dna.a_addr, addr, 2);
-               return dnet_ntop(af, &dna, buf, buflen);
-       }
+       { "nexthop",    do_ipnh },
+       { "mptcp",      do_mptcp },
+       { "ioam",       do_ioam6 },
 +#endif
-       case AF_PACKET:
-               return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
-       case AF_BRIDGE:
+       { "help",       do_help },
+       { 0 }
+ };
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -3,6 +3,10 @@ include ../config.mk
 +  CFLAGS += -DIPROUTE2_TINY
 +endif
 +
- UTILOBJ = utils.o rt_names.o ll_map.o ll_types.o ll_proto.o ll_addr.o \
-       inet_proto.o namespace.o json_writer.o json_print.o \
-       names.o color.o bpf.o exec.o fs.o
+ UTILOBJ = utils.o utils_math.o rt_names.o ll_map.o ll_types.o ll_proto.o ll_addr.o \
+       inet_proto.o namespace.o json_writer.o json_print.o json_print_math.o \
+       names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o