iproute2: update to 4.16
[openwrt/openwrt.git] / package / network / utils / iproute2 / patches / 300-ip_tiny.patch
index d06e91e372b563e129822eb54a3c95baa5586ea2..d8f39d39107ae5165585ffa1c9e3da587bdf239e 100644 (file)
@@ -89,7 +89,7 @@
        { "help",       do_help },
 --- a/lib/utils.c
 +++ b/lib/utils.c
-@@ -885,6 +885,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -983,6 +983,7 @@ const char *rt_addr_n2a_r(int af, int le
                return inet_ntop(af, addr, buf, buflen);
        case AF_MPLS:
                return mpls_ntop(af, addr, buf, buflen);
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
-@@ -894,6 +895,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -992,6 +993,7 @@ const char *rt_addr_n2a_r(int af, int le
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
 +#endif
        case AF_PACKET:
                return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
-       default:
+       case AF_BRIDGE:
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -3,6 +3,10 @@ include ../config.mk