umbim: add netifd proto handler for mbim style lte modems
[openwrt/staging/yousong.git] / package / network / utils / umbim / Makefile
diff --git a/package/network/utils/umbim/Makefile b/package/network/utils/umbim/Makefile
new file mode 100644 (file)
index 0000000..a660f88
--- /dev/null
@@ -0,0 +1,45 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=umbim
+PKG_VERSION:=2014-08-22
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.openwrt.org/project/umbim.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=b82f187ab204a56f5ed7cd6d4de64bfdc07a1a74
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/umbim
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libubox +kmod-usb-net +kmod-usb-net-cdc-mbim
+  TITLE:=Control utility for mobile broadband modems
+endef
+
+define Package/umbim/description
+  umbim is a command line tool for controlling mobile broadband modems using
+  the MBIM-protocol.
+endef
+
+TARGET_CFLAGS += \
+       -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
+
+define Package/umbim/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/umbim $(1)/sbin/
+       $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,umbim))