openssl: update to 1.0.0c
[openwrt/svn-archive/archive.git] / package / openssl / patches / 160-disable_doc_tests.patch
index 32a6d29300e92c4c4fbb3f592c0b1ac40e548c68..4ae35b1b6f42d3a974a1d1e8efdcdc4fedcea9c5 100644 (file)
@@ -1,15 +1,15 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -133,7 +133,7 @@ FIPSCANLIB=
- BASEADDR=0xFB00000
+@@ -111,7 +111,7 @@ LIBKRB5=
+ ZLIB_INCLUDE=
+ LIBZLIB=
  
 -DIRS=   crypto ssl engines apps test tools
 +DIRS=   crypto ssl engines apps tools
+ ENGDIRS= ccgost
  SHLIBDIRS= crypto ssl
  
- # dirs in crypto to build
-@@ -150,7 +150,7 @@ SDIRS=  \
+@@ -129,7 +129,7 @@ SDIRS=  \
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
@@ -18,7 +18,7 @@
  
  MAKEFILE= Makefile
  
-@@ -162,7 +162,7 @@ SHELL=/bin/sh
+@@ -143,7 +143,7 @@ SHELL=/bin/sh
  
  TOP=    .
  ONEDIRS=out tmp
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -321,7 +321,7 @@ FIPS_EX_OBJ= ../crypto/aes/aes_cfb.o \
-       ../crypto/uid.o
+@@ -239,7 +239,7 @@ reflect:
+       @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
  
  sub_all: build_all
 -build_all: build_libs build_apps build_tests build_tools
 +build_all: build_libs build_apps build_tools
  
- build_libs: build_crypto build_fips build_ssl build_shared build_engines
+ build_libs: build_crypto build_ssl build_engines
  
-@@ -613,7 +613,7 @@ dist:   
+@@ -494,7 +494,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -47,7 +47,7 @@
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -611,7 +611,7 @@ dist:   
+@@ -492,7 +492,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)