added light edition of spca5xx driver and the streamin server+web-applet
[openwrt/staging/wigyori.git] / package / spca5xx-le / Makefile
diff --git a/package/spca5xx-le/Makefile b/package/spca5xx-le/Makefile
new file mode 100644 (file)
index 0000000..82faba6
--- /dev/null
@@ -0,0 +1,44 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7137 2007-05-08 18:40:02Z nbd $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spca5xx-le
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME).tar.bz2
+PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt/
+PKG_MD5SUM:=
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/spca5xx-le
+  SUBMENU:=Other modules
+  DEPENDS:=@LINUX_2_6 kmod-videodev @VIDEO_SUPPORT
+  TITLE:=Driver for SPCA5xx based USB cameras (Light Edition)
+  URL:=http://mxhaard.free.fr/
+  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,spca5xx)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(LINUX_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               KERNELVERSION="$(KERNEL)" \
+               KERNEL_VERSION="$(LINUX_VERSION)" \
+               KERNELDIR="$(LINUX_DIR)" \
+               SUBDIRS="$(PKG_BUILD_DIR)" \
+               modules
+endef
+
+$(eval $(call KernelPackage,spca5xx-le))