add _GNU_SOURCE to CPPFLAGS required to include <bits/socket.h> on recent eglibc...
[openwrt/openwrt.git] / package / swconfig / Makefile
index d22fa628f910dff0cc8ea243735524bb530bdcf9..a7bed73174d768f50bf25cfb158fcedb96d9a5cd 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=swconfig
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -21,6 +21,7 @@ define Package/swconfig
 endef
 
 TARGET_CPPFLAGS := \
+       -D_GNU_SOURCE \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        -I$(LINUX_DIR)/include \
        -I$(PKG_BUILD_DIR) \
@@ -39,8 +40,8 @@ define Build/Compile
 endef
 
 define Package/swconfig/install
-       $(INSTALL_DIR) $(1)/bin $(1)/lib/network
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/swconfig $(1)/bin/swconfig
+       $(INSTALL_DIR) $(1)/sbin $(1)/lib/network
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/swconfig $(1)/sbin/swconfig
        $(INSTALL_DATA) ./files/switch.sh $(1)/lib/network/
 endef