package/uboot-envtools: generate config-file from UCI
[openwrt/svn-archive/archive.git] / package / uboot-envtools / Makefile
index 600697f1468c1e017fcd3737187fa0ecd37d7296..19aebc215f5cd3aeda1e0ffc976adddd36e89361 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2011.06
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
@@ -36,6 +36,8 @@ define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
        ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/uboot-envtools.init $(1)/etc/init.d/uboot-envtools
 endef
 
 define Build/Prepare