[boot] move boot related packages to their own folder
[openwrt/svn-archive/archive.git] / package / uboot-kirkwood / Makefile
diff --git a/package/uboot-kirkwood/Makefile b/package/uboot-kirkwood/Makefile
deleted file mode 100644 (file)
index 48bcf99..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
-#
-# Copyright (C) 2010-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=u-boot
-PKG_VERSION:=2012.04.01
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=192bb231082d9159fb6e16de3039b6b2
-PKG_TARGETS:=bin
-
-include $(INCLUDE_DIR)/package.mk
-
-define uboot/Default
-  TITLE:=
-  CONFIG:=
-  IMAGE:=
-endef
-
-define uboot/sheevaplug
-  TITLE:=U-Boot for the SheevaPlug
-endef
-
-define uboot/dockstar
-  TITLE:=U-Boot for the Seagate DockStar
-endef
-
-define uboot/iconnect
-  TITLE:=U-Boot for the Iomega iConnect Wireless
-endef
-
-define uboot/ib62x0
-  TITLE:=U-Boot for the RaidSonic ICY BOX NAS6210 and NAS6220
-endef
-
-UBOOTS:=sheevaplug dockstar iconnect ib62x0
-
-define Package/uboot/template
-define Package/uboot-kirkwood-$(1)
-  SECTION:=boot
-  CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_kirkwood
-  TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/U-Boot
-  VARIANT:=$(1)
-endef
-endef
-
-define BuildUBootPackage
-       $(eval $(uboot/Default))
-       $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE))
-endef
-
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
-
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       $(CP) ./files/* $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(UBOOT_CONFIG)_config
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               u-boot.kwb \
-               CROSS_COMPILE=$(TARGET_CROSS)
-endef
-
-define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)
-       $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
-               $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
-       $(CP) $(PKG_BUILD_DIR)/u-boot.kwb \
-               $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.kwb
-       $(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
-       $(CP) $(PKG_BUILD_DIR)/tools/kwboot \
-               $(BIN_DIR)/u-boot-kwboot/
-endef
-
-define Package/uboot/install/template
-define Package/uboot-kirkwood-$(1)/install
-       $(call Package/uboot/install/default,$(2))
-endef
-endef
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call BuildUBootPackage,$(u))) \
-       $(eval $(call BuildPackage,uboot-kirkwood-$(u))) \
-)