massive: replace occurences of .$(LINUX_KMOD_SUFFIX) with .ko after r21950
[openwrt/openwrt.git] / package / ubsec_ssb / Makefile
index 521b96194e36ef0e4a1ff21860a7d4b649727883..bac2aabcbbfa355ccd8ce979851702b48415bce6 100644 (file)
@@ -4,12 +4,13 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ubsec-ssb
+PKG_VERSION:=2009-02-21
+PKG_RELEASE:=1
 
 CRYPTO_MENU:=OCF Configuration
 
@@ -17,9 +18,9 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/ocf-ubsec-ssb
   SUBMENU:=$(CRYPTO_MENU)
-  DEPENDS:=@TARGET_brcm47xx +kmod-crypto-ocf
+  DEPENDS:=@TARGET_brcm47xx +kmod-crypto-core +kmod-crypto-ocf
   TITLE:=BCM5365P IPSec Core driver
-  FILES:=$(PKG_BUILD_DIR)/src/ubsec_ssb.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(PKG_BUILD_DIR)/src/ubsec_ssb.ko
   AUTOLOAD:=$(call AutoLoad,09,ubsec_ssb)
 endef