oseama: small util for reading Seama image format info
[openwrt/staging/hauke.git] / package / utils / oseama / Makefile
diff --git a/package/utils/oseama/Makefile b/package/utils/oseama/Makefile
new file mode 100644 (file)
index 0000000..ad1395c
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=oseama
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/oseama
+  SECTION:=utils
+  CATEGORY:=Base system
+  TITLE:=Utility for handling Seama firmware images
+  MAINTAINER:=Rafał Miłecki <zajec5@gmail.com>
+  DEPENDS:=@TARGET_bcm53xx
+endef
+
+define Package/oseama/description
+ This package contains an utility that allows handling Seama images.
+endef
+
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) -Wall"
+endef
+
+define Package/oseama/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/oseama $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,oseama))