tag rc6
[openwrt/svn-archive/openwrt.git] / package / wput / Makefile
diff --git a/package/wput/Makefile b/package/wput/Makefile
new file mode 100644 (file)
index 0000000..bbe8343
--- /dev/null
@@ -0,0 +1,60 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wput
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=441b2e07219f78167b29a7ac33488fff
+
+PKG_SOURCE_URL:=http://itooktheredpill.dyndns.org/wput/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WPUT,wput,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --disable-static \
+                 --disable-g-switch \
+       )
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       touch $@
+
+$(IPKG_WPUT):
+       install -d -m0755 $(IDIR_WPUT)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/wput $(IDIR_WPUT)/usr/bin/
+       $(RSTRIP) $(IDIR_WPUT)
+       $(IPKG_BUILD) $(IDIR_WPUT) $(PACKAGE_DIR)
+