alsa-utils: Update to 1.2.2
[feed/packages.git] / sound / alsa-utils / Makefile
index 9a1d863a7046ec723f763a6d4f3bc2dc56642f19..dccee76c5ec47e4100368ceda4623cf2c7184f69 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alsa-utils
-PKG_VERSION:=1.1.9
+PKG_VERSION:=1.2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
                http://distfiles.gentoo.org/distfiles/
-PKG_HASH:=5ddf2cbddb4bd1a4a2a6492a09c25898b08c3ad64893c3655be14194cf0a213a
+PKG_HASH:=44807bd578c5f6df6e91a11b8d37e546424a5a1ea8d8e659ee359fe01730e4f3
 
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 PKG_LICENSE:=GPL-2.0-or-later
@@ -50,7 +50,7 @@ define Package/alsa-utils-tests
   URL:=https://www.alsa-project.org/
 endef
 
-CONFIGURE_ARGS+= \
+CONFIGURE_ARGS += \
        --disable-rpath \
        --disable-alsatest \
        --disable-bat \
@@ -58,6 +58,11 @@ CONFIGURE_ARGS+= \
        --disable-rst2man \
        --with-curses=ncursesw
 
+CONFIGURE_VARS += \
+       ac_cv_header_samplerate_h=no
+
+TARGET_LDFLAGS += -latopology
+
 define Package/alsa-utils/install
        $(INSTALL_DIR) $(1)/usr/{s,}bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amixer $(1)/usr/bin/