Put back 2.6.23 files for rdc, allowing to switch from one kernel version to another...
[openwrt/openwrt.git] / target / linux / Makefile
index 2a9cf7db2d0e1223c03761cb9431d647a41bcf47..1bdd5ae1496ccaf5b5ee3d919dedaff3ad1a0000 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,17 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
+export TARGET_BUILD=1
 
-prepare:
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean
+prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+       @$(NO_TRACE_MAKE) -C $(BOARD) $@