[adm5120] initial 2.6.26 support
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / patches-2.6.26 / 103-mtd_trxsplit.patch
diff --git a/target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch
new file mode 100644 (file)
index 0000000..267293a
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -57,6 +57,11 @@
+       depends on MTD_PARTITIONS
+       default y
++config MTD_TRXSPLIT
++      bool "Automatically find and split TRX partitions"
++      depends on MTD_PARTITIONS
++      default n
++
+ config MTD_REDBOOT_PARTS
+       tristate "RedBoot partition table parsing"
+       depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@
+ mtd-$(CONFIG_MTD_PARTITIONS)  += mtdpart.o
+ obj-$(CONFIG_MTD_CONCAT)      += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT)    += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o