apm821xx: prepare WNDR4700 for 6.6 - add preliminary u-boot-env access
[openwrt/openwrt.git] / target / linux / apm821xx / image / nand.mk
index 469bf58c1d107d9c139f90c87c4ee54142aded69..69eb386126a9c025c6d4832134df9847c85bbda3 100644 (file)
@@ -105,7 +105,7 @@ define Device/netgear_wndr4700
   IMAGE_SIZE := 24960k
   IMAGES := factory.img sysupgrade.bin
   ARTIFACTS := device-tree.dtb
-  KERNEL_SIZE := 3584k
+  KERNEL_SIZE := 4608k
   # append a fake/empty rootfs to fool netgear's uboot
   # CHECK_DNI_FIRMWARE_ROOTFS_INTEGRITY in do_chk_dniimg()
   KERNEL := kernel-bin | lzma -d16 | uImage lzma | pad-offset $$(BLOCKSIZE) 64 | \
@@ -119,5 +119,8 @@ define Device/netgear_wndr4700
   NETGEAR_HW_ID := 29763875+128+256
   UBINIZE_OPTS := -E 5
   SUPPORTED_DEVICES += wndr4700
+  DEVICE_COMPAT_VERSION := 2.0
+  DEVICE_COMPAT_MESSAGE := kernel and ubi partitions had to be resized. \
+       Upgrade via sysupgrade mechanism is not possible.
 endef
 TARGET_DEVICES += netgear_wndr4700