kernel: update 3.10.36->3.10.44
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index 0beb8ae75d7644fb2dbe0f7123e128e7133035ea..1d0237c9ae086ed364725d4f77544afca702b257 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
+FEATURES:=squashfs atm
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=3.10.44
 
-define Target/Description
-       Build firmware images for TI AR7 based routers
-endef
+include $(INCLUDE_DIR)/target.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES+= swconfig
 
--include profiles/*.mk
+define Target/Description
+       Build firmware images for TI AR7 based routers.
+endef
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))