ar71xx: WNR612v2: exclude USB modules from image
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index 16b1087635df49e1c2cb61ec47675cdfa27de5b4..32c692aa8d3490a6a5b8b087ef6a3274612df76f 100644 (file)
@@ -30,6 +30,7 @@ $(eval $(call Profile,WNDR3700))
 
 define Profile/WNR2000V3
        NAME:=NETGEAR WNR2000V3
+       PACKAGES:= -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-ledtrig-usbdev
 endef
 
 define Profile/WNR2000V3/Description
@@ -53,6 +54,7 @@ $(eval $(call Profile,WNR2000V4))
 
 define Profile/WNR612V2
        NAME:=NETGEAR WNR612V2 / On Networks N150
+       PACKAGES:= -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-ledtrig-usbdev
 endef
 
 define Profile/WNR612V2/Description
@@ -82,3 +84,13 @@ define Profile/WNR2200/Description
 endef
 
 $(eval $(call Profile,WNR2200))
+
+define Profile/WPN824N
+       NAME:=NETGEAR WPN824N
+endef
+
+define Profile/WPN824N/Description
+       Package set optimized for the NETGEAR WPN824N
+endef
+
+$(eval $(call Profile,WPN824N))