ar71xx: add 2.6.39 support
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / patches-2.6.39 / 153-spi-rb4xx-cpld-driver.patch
diff --git a/target/linux/ar71xx/patches-2.6.39/153-spi-rb4xx-cpld-driver.patch b/target/linux/ar71xx/patches-2.6.39/153-spi-rb4xx-cpld-driver.patch
new file mode 100644 (file)
index 0000000..2c01c54
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -479,6 +479,13 @@ config SPI_TLE62X0
+         sysfs interface, with each line presented as a kind of GPIO
+         exposing both switch control and diagnostic feedback.
++config SPI_RB4XX_CPLD
++      tristate "MikroTik RB4XX CPLD driver"
++      depends on AR71XX_MACH_RB4XX
++      help
++        SPI driver for the Xilinx CPLD chip present on the
++        MikroTik RB4xx boards.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -65,6 +65,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
+ #     ... add above this line ...
+ # SPI protocol drivers (device/link on bus)
++obj-$(CONFIG_SPI_RB4XX_CPLD)  += spi_rb4xx_cpld.o
+ obj-$(CONFIG_SPI_SPIDEV)      += spidev.o
+ obj-$(CONFIG_SPI_TLE62X0)     += tle62x0.o
+ #     ... add above this line ...