ar71xx: remove linux 3.10 support
[openwrt/openwrt.git] / target / linux / ar71xx / patches-3.10 / 714-MIPS-ath79-add-TL-WA830REv2-support.patch
diff --git a/target/linux/ar71xx/patches-3.10/714-MIPS-ath79-add-TL-WA830REv2-support.patch b/target/linux/ar71xx/patches-3.10/714-MIPS-ath79-add-TL-WA830REv2-support.patch
deleted file mode 100644 (file)
index aedc1bf..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -656,6 +656,16 @@ config ATH79_MACH_TL_WAX50RE
-       select ATH79_DEV_M25P80
-       select ATH79_DEV_WMAC
-+config ATH79_MACH_TL_WA830RE_V2
-+      bool "TP-LINK TL-WA830RE v2 support"
-+      select SOC_AR934X
-+      select ATH79_DEV_ETH
-+      select ATH79_DEV_GPIO_BUTTONS
-+      select ATH79_DEV_LEDS_GPIO
-+      select ATH79_DEV_M25P80
-+      select ATH79_DEV_USB
-+      select ATH79_DEV_WMAC
-+
- config ATH79_MACH_TL_WA901ND
-       bool "TP-LINK TL-WA901ND/TL-WA7510N support"
-       select SOC_AR724X
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -96,6 +96,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR13U)    += mac
- obj-$(CONFIG_ATH79_MACH_TL_MR3020)    += mach-tl-mr3020.o
- obj-$(CONFIG_ATH79_MACH_TL_MR3X20)    += mach-tl-mr3x20.o
- obj-$(CONFIG_ATH79_MACH_TL_WAX50RE)     += mach-tl-wax50re.o
-+obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2)        += mach-tl-wa830re-v2.o
- obj-$(CONFIG_ATH79_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
- obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2)        += mach-tl-wa901nd-v2.o
- obj-$(CONFIG_ATH79_MACH_TL_WDR3500)     += mach-tl-wdr3500.o
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -114,6 +114,7 @@ enum ath79_mach_type {
-       ATH79_MACH_TL_WA7510N_V1,       /* TP-LINK TL-WA7510N v1*/
-       ATH79_MACH_TL_WA850RE,          /* TP-LINK TL-WA850RE */
-       ATH79_MACH_TL_WA801ND_V2,       /* TP-LINK TL-WA801ND v2 */
-+      ATH79_MACH_TL_WA830RE_V2,       /* TP-LINK TL-WA830RE v2 */
-       ATH79_MACH_TL_WA901ND,          /* TP-LINK TL-WA901ND */
-       ATH79_MACH_TL_WA901ND_V2,       /* TP-LINK TL-WA901ND v2 */
-       ATH79_MACH_TL_WA901ND_V3,       /* TP-LINK TL-WA901ND v3 */