linux: add support of Synopsys ARC770-based boards
[openwrt/staging/florian.git] / target / linux / arc770 / Makefile
diff --git a/target/linux/arc770/Makefile b/target/linux/arc770/Makefile
new file mode 100644 (file)
index 0000000..f62bf0e
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arc
+BOARD:=arc770
+BOARDNAME:=Synopsys DesignWare ARC 770D
+CFLAGS:=-Os -pipe -fno-caller-saves -matomic
+MAINTAINER:=Alexey Brodkin <abrodkin@synopsys.com>
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=4.3
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+       Synopsys DesignWare boards
+endef
+
+$(eval $(call BuildTarget))