linux: add support of Synopsys ARCHS38-based boards
[openwrt/svn-archive/archive.git] / target / linux / archs38 / Makefile
diff --git a/target/linux/archs38/Makefile b/target/linux/archs38/Makefile
new file mode 100644 (file)
index 0000000..166d3d5
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arc
+CPU_TYPE:=archs
+BOARD:=archs38
+BOARDNAME:=Synopsys DesignWare ARC HS38
+MAINTAINER:=Alexey Brodkin <abrodkin@synopsys.com>
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=4.4
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+       Synopsys DesignWare boards
+endef
+
+$(eval $(call BuildTarget))