target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / armvirt / Makefile
index 107f8607c33b8911a1411e205890395ebf8b5cc2..bf069952d96a0c969fb900d8ccae0ebd81a216bc 100644 (file)
@@ -1,20 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=armvirt
 BOARDNAME:=QEMU ARM Virtual Machine
 FEATURES:=fpu pci rtc usb
 FEATURES+=cpiogz ext4 ramdisk squashfs targz
-MAINTAINER:=Florian Fainelli <f.fainelli@gmail.com>, \
-       Yousong Zhou <yszhou4tech@gmail.com>
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))