target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / armvirt / Makefile
index 3fedcad0a045f2a7834e4731df269cacf8285bc5..bf069952d96a0c969fb900d8ccae0ebd81a216bc 100644 (file)
@@ -1,28 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=armvirt
 BOARDNAME:=QEMU ARM Virtual Machine
 FEATURES:=fpu pci rtc usb
 FEATURES+=cpiogz ext4 ramdisk squashfs targz
-CPU_TYPE:=cortex-a15
-CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
-
-KERNEL_PATCHVER:=4.4
 
-define Target/Description
-  Build images for QEMU ARM Virtual Machine
-endef
+KERNEL_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:=zImage
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))