give Aruba some love - add support for the combined flash layout
[openwrt/openwrt.git] / target / linux / aruba-2.6 / patches / 000-aruba.patch
index 48143bdeed4a3fa84e9b107c409117802b3db2ee..1f61424b493e1a3558967ef253fbecc01819583f 100644 (file)
@@ -630,9 +630,9 @@ diff -Nur linux-2.6.17/arch/mips/aruba/prom.c linux-2.6.17-owrt/arch/mips/aruba/
 +
 +/* Kernel Boot parameters */
 +static unsigned char bootparm[] = 
-+      "mtdparts=physmap-flash.0:3520k@0x080000(zImage),2752k@0x140000(JFFS2),8k@0x3f8000(NVRAM) "
-+      "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=jffs2 ";
-+
++      "init=/etc/preinit noinitrd "
++      "mtdparts=physmap-flash.0:3520k@0x080000(kernel),2752k@0x140000(rootfs),8k@0x3f8000(NVRAM) "
++      "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=squashfs,jffs2 ";
 +
 +extern unsigned long mips_machgroup;
 +extern unsigned long mips_machtype;
@@ -1068,25 +1068,6 @@ diff -Nur linux-2.6.17/arch/mips/Makefile linux-2.6.17-owrt/arch/mips/Makefile
  # Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
  #
  core-$(CONFIG_MACH_JAZZ)      += arch/mips/jazz/
-diff -Nur linux-2.6.17/arch/mips/mm/tlbex.c linux-2.6.17-owrt/arch/mips/mm/tlbex.c
---- linux-2.6.17/arch/mips/mm/tlbex.c  2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17-owrt/arch/mips/mm/tlbex.c     2006-06-18 12:48:27.000000000 +0200
-@@ -876,7 +876,6 @@
-       case CPU_R10000:
-       case CPU_R12000:
-       case CPU_R14000:
--      case CPU_4KC:
-       case CPU_SB1:
-       case CPU_SB1A:
-       case CPU_4KSC:
-@@ -904,6 +903,7 @@
-               tlbw(p);
-               break;
-+      case CPU_4KC:
-       case CPU_4KEC:
-       case CPU_24K:
-       case CPU_34K:
 diff -Nur linux-2.6.17/drivers/net/Kconfig linux-2.6.17-owrt/drivers/net/Kconfig
 --- linux-2.6.17/drivers/net/Kconfig   2006-06-18 03:49:35.000000000 +0200
 +++ linux-2.6.17-owrt/drivers/net/Kconfig      2006-06-18 12:44:28.000000000 +0200