at91: reorganize at91 subtargets
[openwrt/openwrt.git] / target / linux / at91 / image / sama5d4.mk
diff --git a/target/linux/at91/image/sama5d4.mk b/target/linux/at91/image/sama5d4.mk
new file mode 100644 (file)
index 0000000..554b989
--- /dev/null
@@ -0,0 +1,19 @@
+
+define Device/default-nand
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 2048
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d4_xplained
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+  KERNEL_SIZE := 6144k
+  BLOCKSIZE := 256k
+  PAGESIZE := 4096
+  SUBPAGESIZE := 2048
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+  $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d4_xplained