ath79: reorganize common image definitions for Netgear
[openwrt/openwrt.git] / target / linux / ath79 / image / common-buffalo.mk
index 8870af691ef225d4a238378fa556cbdea63db4d8..d62b7eea942adf69b8d976918549037485606712 100644 (file)
@@ -1,11 +1,3 @@
-define Build/buffalo-tftp-header
-       ( \
-               echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
-               dd if=$@; \
-       ) > $@.new
-  mv $@.new $@
-endef
-
 define Build/buffalo-tag
        $(eval product=$(word 1,$(1)))
        $(eval hwver=$(word 2,$(1)))
@@ -18,4 +10,10 @@ define Build/buffalo-tag
        mv $@.new $@
 endef
 
-
+define Build/buffalo-tftp-header
+       ( \
+               echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
+               dd if=$@; \
+       ) > $@.new
+       mv $@.new $@
+endef