ath79: Add support for Ubiquiti Nanostation AC
[openwrt/staging/lynxis.git] / target / linux / ath79 / image / generic-ubnt.mk
index 86afa11deb8f5e43c4f72e7722c2a1b1d3f4ec6d..91cd5fc681c484c9435ae853a8346de14df99589 100644 (file)
@@ -84,6 +84,16 @@ define Device/ubnt_nano-m
 endef
 TARGET_DEVICES += ubnt_nano-m
 
+define Device/ubnt_nanostation-ac
+  $(Device/ubnt-wa)
+  DEVICE_TITLE := Ubiquiti Nanostation AC
+  DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+  IMAGE_SIZE := 15744k
+  IMAGES += factory.bin
+  IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+endef
+TARGET_DEVICES += ubnt_nanostation-ac
+
 define Device/ubnt_nanostation-ac-loco
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti Nanostation AC loco