ath79: support Ruckus ZoneFlex 7341/7343/7363
[openwrt/staging/wigyori.git] / target / linux / ath79 / image / generic.mk
index fd63b623cdedf181cd75faa608e706babed56326..608b51766fa4f969d752f8367b64dbb3fc878183 100644 (file)
@@ -2538,6 +2538,13 @@ define Device/ruckus_gd11_common
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-chipidea2
 endef
 
+define Device/ruckus_zf7341
+  $(Device/ruckus_gd11_common)
+  DEVICE_MODEL := ZoneFlex 7341[-U]
+  DEVICE_PACKAGES += -swconfig
+endef
+TARGET_DEVICES += ruckus_zf7341
+
 define Device/ruckus_zf7351
   $(Device/ruckus_gd11_common)
   DEVICE_MODEL := ZoneFlex 7351[-U]
@@ -2545,6 +2552,14 @@ define Device/ruckus_zf7351
 endef
 TARGET_DEVICES += ruckus_zf7351
 
+define Device/ruckus_zf7363
+  $(Device/ruckus_gd11_common)
+  DEVICE_MODEL := ZoneFlex 7363[-U]
+  DEVICE_ALT0_VENDOR := Ruckus
+  DEVICE_ALT0_MODEL := ZoneFlex 7343[-U]
+endef
+TARGET_DEVICES += ruckus_zf7363
+
 define Device/ruckus_zf73xx_common
   $(Device/ruckus_common)
   DEVICE_PACKAGES := -swconfig kmod-usb2 kmod-usb-chipidea2