ath79: add support for I-O DATA WN-AC1600DGR
[openwrt/staging/jogo.git] / target / linux / ath79 / image / generic.mk
index 94dfe3d4d7f1fe1c945e91a5350002a55f981a3d..889321867a50fd51ffc1689697707bd242bb334e 100644 (file)
@@ -349,6 +349,18 @@ define Device/iodata_wn-ac1167dgr
 endef
 TARGET_DEVICES += iodata_wn-ac1167dgr
 
+define Device/iodata_wn-ac1600dgr
+  ATH_SOC := qca9557
+  DEVICE_TITLE := I-O DATA WN-AC1600DGR
+  IMAGE_SIZE := 14656k
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+    append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+    senao-header -r 0x30a -p 0x60 -t 2 -v 200
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += iodata_wn-ac1600dgr
+
 define Device/iodata_wn-ac1600dgr2
   ATH_SOC := qca9557
   DEVICE_TITLE := I-O DATA WN-AC1600DGR2